Bug 826706 - NetworkManager update breaks applet, vpnc & openvpn
NetworkManager update breaks applet, vpnc & openvpn
Status: CLOSED DUPLICATE of bug 817851
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 826365 829258 833108 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 15:57 EDT by Terry Bowling
Modified: 2012-12-22 19:22 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
$ cat /etc/fedora-release Fedora release 16 (Verne) $ uname -a Linux tabserver.local 3.3.7-1.fc16.x86_64 #1 SMP Tue May 22 13:59:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux $ sudo yum list NetworkM* Installed Packages NetworkManager.x86_64 1:0.9.4-6.git20120521.fc16 @updates NetworkManager-glib.x86_64 1:0.9.4-6.git20120521.fc16 @updates NetworkManager-gnome.x86_64 1:0.9.4-6.git20120521.fc16 @updates NetworkManager-gtk.x86_64 1:0.9.4-6.git20120521.fc16 @updates NetworkManager-openconnect.x86_64 0.9.0-3.fc16 @updates NetworkManager-openvpn.x86_64 1:0.9.0-1.fc16 @fedora NetworkManager-pptp.x86_64 1:0.9.0-1.fc16 @fedora NetworkManager-vpnc.x86_64 1:0.9.0-1.fc16 @fedora
Last Closed: 2012-07-10 08:04:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsession-errors extract (3.55 KB, text/plain)
2012-06-05 05:29 EDT, marianne@tuxette.fr
no flags Details
/var/log/messages extract (24.27 KB, text/plain)
2012-06-05 11:21 EDT, marianne@tuxette.fr
no flags Details
/var/log/messages (117.35 KB, text/plain)
2012-06-07 09:16 EDT, Phil Clayton
no flags Details
Xsession-errors (4.02 KB, text/plain)
2012-06-12 09:42 EDT, Graeme Frear
no flags Details
From update to shutdown (1.54 MB, text/plain)
2012-06-12 09:44 EDT, Graeme Frear
no flags Details

  None (edit)
Description Terry Bowling 2012-05-30 15:57:43 EDT
Description of problem:

     Update of NetworkManager* packages breaks nm-applet and vpn functionality

     NetworkManager applet no longer appears to display status or to provide dropdown menu functionality.

     When launching the Network Configuration GUI from the Applications->System Tools menu, the following error messages appears and all of my network settings are gone, including my vpnc and openvpn profiles

           "The system network services are not compatible with this version.


Version-Release number of selected component (if applicable):

Installed Packages
NetworkManager.x86_64                      1:0.9.4-6.git20120521.fc16           @updates
NetworkManager-glib.x86_64                 1:0.9.4-6.git20120521.fc16           @updates
NetworkManager-gnome.x86_64                1:0.9.4-6.git20120521.fc16           @updates
NetworkManager-gtk.x86_64                  1:0.9.4-6.git20120521.fc16           @updates
NetworkManager-openconnect.x86_64          0.9.0-3.fc16                         @updates
NetworkManager-openvpn.x86_64              1:0.9.0-1.fc16                       @fedora 
NetworkManager-pptp.x86_64                 1:0.9.0-1.fc16                       @fedora 
NetworkManager-vpnc.x86_64                 1:0.9.0-1.fc16                       @fedora 


How reproducible:

Update kernel and NetworkManager
reboot
nm-applet will not be running in gnome.  Try to launch nm-applet manually

Steps to Reproduce:
1. yum -y update NetworkManager*

2. nm-applet
  
Actual results:

  *  NetworkManager applet will not be running in gnome (or xfce) at login.

  *  Launching the Network Configuration GUI from the Applications->System Tools menu, the following error messages appears and all of my network settings are gone, including my vpnc and openvpn profiles

          "The system network services are not compatible with this version.


  *  When manually executing nm-applet command, the following errors occur:

** (nm-applet:4047): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

** Message: applet now removed from the notification area

** (nm-applet:4047): WARNING **: fetch_connections_done: error fetching connections: (19) Method "ListConnections" with signature "" on interface "org.freedesktop.NetworkManager.Settings" doesn't exist
.

** (nm-applet:4047): WARNING **: Failed to register as an agent: (19) Method "Register" with signature "s" on interface "org.freedesktop.NetworkManager.AgentManager" doesn't exist

** Message: applet now embedded in the notification area


Expected results:


Additional info:
Comment 1 Dave Allan 2012-05-30 22:08:17 EDT
I also saw this behavior this morning, as did one of my colleagues.  I upgraded to Fedora 17 so I can't troubleshoot further.  Fedora 17 is working properly.
Comment 2 Daniel 2012-05-31 06:39:13 EDT
I had the same problem and now I have to downgrade NetworkManager packages to use them.
Comment 3 ajs 2012-06-03 00:27:02 EDT
NetworkManager-0.9.4-4.git20120403.fc16.x86_64.rpm works for me
NetworkManager-0.9.4-5.git20120502.fc16.x86_64.rpm does not
Comment 4 Jirka Klimes 2012-06-04 06:39:00 EDT
NetworkManager-0.9.4-5.git20120502.f16 never got to stable.
Please upgrade to NetworkManager-0.9.4-6.git20120521.fc16.
Comment 5 marianne@tuxette.fr 2012-06-04 07:51:15 EDT
Same problem since today with last NetworkManager version. 

package installed : 
NetworkManager-gnome-0.9.4-6.git20120521.fc16.x86_64
NetworkManager-pptp-0.9.0-1.fc16.x86_64
NetworkManager-openvpn-0.9.0-1.fc16.x86_64
NetworkManager-0.9.4-6.git20120521.fc16.x86_64
NetworkManager-gtk-0.9.4-6.git20120521.fc16.x86_64
NetworkManager-vpnc-0.9.0-1.fc16.x86_64
NetworkManager-glib-0.9.4-6.git20120521.fc16.x86_64
NetworkManager-openconnect-0.9.0-3.fc16.x86_64
Comment 6 Terry Bowling 2012-06-04 08:04:51 EDT
I'm using 0.9.4-6.git20120521.fc16, as noted in the initial opening of this BZ.  However, after multiple downgrades, upgrades, and reboots, it is magically working again.

I recommend:
   yum downgrade NetworkManager*
   reboot
   yum upgrade NetworkManager*
   reboot
   spin around 3 times
   preferrably during a full moon

Good luck...
Comment 7 Haricophile 2012-06-04 08:14:41 EDT
Is there something related to https://bugzilla.redhat.com/show_bug.cgi?id=756245 ?
Comment 8 ajs 2012-06-04 23:45:42 EDT
(In reply to comment #4)
> NetworkManager-0.9.4-5.git20120502.f16 never got to stable.
> Please upgrade to NetworkManager-0.9.4-6.git20120521.fc16.

_Obviously_ NetworkManager-0.9.4-6.git20120521.fc16 does not work.  I wouldn't have bothered to check to see if there was Bugzilla ticket if it had been working.

Rather than the ever helpful 'me too' I was pointing out that the problem occurs in the delta between NetworkManager-0.9.4-4.git20120403.fc16.x86_64.rpm and NetworkManager-0.9.4-5.git20120502.fc16.x86_64.rpm.

Your welcome.
Comment 9 ajs 2012-06-04 23:47:39 EDT
(In reply to comment #8)
> (In reply to comment #4)
> > NetworkManager-0.9.4-5.git20120502.f16 never got to stable.
> > Please upgrade to NetworkManager-0.9.4-6.git20120521.fc16.
> 
> _Obviously_ NetworkManager-0.9.4-6.git20120521.fc16 does not work.  I
> wouldn't have bothered to check to see if there was Bugzilla ticket if it
> had been working.
> 
> Rather than the ever helpful 'me too' I was pointing out that the problem
> occurs in the delta between
> NetworkManager-0.9.4-4.git20120403.fc16.x86_64.rpm and
> NetworkManager-0.9.4-5.git20120502.fc16.x86_64.rpm.
> 
> Your welcome.

That should be "You're welcome".

Sorry.
Comment 10 Jirka Klimes 2012-06-05 04:26:37 EDT
Well, would anyone having the issue gather logs and other info?

* /var/log/messages
* ~/.xsession-errors
* do you have SELinux enabled?, do you get AVC's? (ausearch -m avc)
* $ nmcli nm
Comment 11 marianne@tuxette.fr 2012-06-05 05:29:39 EDT
Created attachment 589451 [details]
xsession-errors extract

ncmli nm return : 
[mlombard@JBSX5R1 ~]$ nmcli nm

** (process:5753): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

Erreur : les versions de nmcli (0.9.4.0) et de NetworkManager (inconnu) ne correspondent pas. L'exécution peut être forcée avec --nocheck, mais les résultats sont imprévisibles.


Error message is in french, sorry, but it says thant nmcli and NetworkManager version don't match. 

SELinux is in permissive mode 

I join an extract of the .xsession-errors
Comment 12 Jirka Klimes 2012-06-05 06:17:19 EDT
Is NetworkManager running at all?

$ ps aux | grep NetworkManager
and also
$ ps aux | grep dbus

Does restarting NetworkManager change anything?
# systemctl restart NetworkManager.service

Please attach /var/log/messages file too.
Comment 13 marianne@tuxette.fr 2012-06-05 11:21:31 EDT
Created attachment 589560 [details]
/var/log/messages extract

NetworkManager run 


[mlombard@JBSX5R1 ~]$ ps aux | grep NetworkManager
root      1030  0.0  0.0 279796  5480 ?        Ssl  08:16   0:00 /usr/sbin/NetworkManager --no-daemon
mlombard 18579  0.0  0.0 111332   932 pts/4    S+   17:17   0:00 grep --color=auto NetworkManager
[mlombard@JBSX5R1 ~]$ ps aux | grep dbus
dbus      1811  0.0  0.0  31080  2848 ?        Ssl  08:16   0:00 /bin/dbus-daemon --system --address=systemd: --nofork --systemd-activation
mlombard  2032  0.0  0.0  22360   480 ?        S    08:16   0:00 dbus-launch --sh-syntax --exit-with-session
mlombard  2033  0.0  0.0  33156  3028 ?        Ssl  08:16   0:31 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
mlombard 18607  0.0  0.0 111332   928 pts/4    S+   17:17   0:00 grep --color=auto dbus

Restarting Networkmanager doesn't change anything

Join : /var/log/messages extract (corresponding at the NM restart)
Comment 14 marianne@tuxette.fr 2012-06-06 02:57:41 EDT
Working again this morning ... no change, no update, nothing done 

An unsolved mystery of computing science
Comment 15 Jirka Klimes 2012-06-06 03:09:21 EDT
Oops, there were crashes of NM and nm-applet:

Jun  5 17:18:18 JBSX5R1 abrtd: Directory 'ccpp-2012-06-05-17:18:17-1030' creation detected
Jun  5 17:18:18 JBSX5R1 abrt[18814]: Saved core dump of pid 1030 (/usr/sbin/NetworkManager) to /var/spool/abrt/ccpp-2012-06-05-17:18:17-1030 (27246592 bytes)

Jun  5 17:18:21 JBSX5R1 kernel: [26329.818665] nm-applet[2242] trap int3 ip:32c844d783 sp:7fffd86ee6c0 error:0
Jun  5 17:18:22 JBSX5R1 abrt[18867]: Saved core dump of pid 2242 (/usr/bin/nm-applet) to /var/spool/abrt/ccpp-2012-06-05-17:18:21-2242 (20692992 bytes)

Could we have backtraces of them. You should be able to see the backtrace via abrt-gui.
If you you don't have debugging packages installed, please install them using:
# debuginfo-install NetworkManager
# debuginfo-install NetworkManager-gnome
so that we can see details in the backtrace.

Then restart NM and if there is a crash, please report it. Thanks.

(In reply to comment #14)
> Working again this morning ... no change, no update, nothing done 
> 
> An unsolved mystery of computing science
It may depend on various conditions. Perhaps today's transit of Venus across the Sun :)
Let's get the crash backtrace and we will see.
Comment 16 Kolos Tatar 2012-06-06 04:44:15 EDT
Stopped working for me too with these:

NetworkManager-gtk-0.9.4-6.git20120521.fc16.i686
NetworkManager-openconnect-0.9.0-3.fc16.i686
NetworkManager-glib-0.9.4-6.git20120521.fc16.i686
NetworkManager-pptp-0.9.0-1.fc16.i686
NetworkManager-gnome-0.9.4-6.git20120521.fc16.i686
NetworkManager-openvpn-0.9.0-1.fc16.i686
NetworkManager-0.9.4-6.git20120521.fc16.i686
NetworkManager-vpnc-0.9.0-1.fc16.i686

By default, there's no icon for nm-applet.

If I restart NetworkManager, the tray icon appears, but when I try to connect to a VPN connection, no dialog is displayed, and the following is logged in /var/log/messages:

Jun  6 10:16:56 localhost NetworkManager[2450]: <info> Starting VPN service 'vpnc'...
Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN service 'vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 2776
Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN service 'vpnc' appeared; activating connections
Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN plugin state changed: init (1)
Jun  6 10:16:56 localhost NetworkManager[2450]: <error> [1338970616.216254] [nm-vpn-connection.c:934] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

Also, how can I downgrade to the previous version of NetworkManager (the one that works)? The updates repo seems to only contain one version and yum downgrade wants to go back to the originally released one (with F16). The downgrade to this version doesn't even work due to dependency problems. :|

Yum downgrade should go back to the previous version by default imho.

Kolos
Comment 17 Dan Williams 2012-06-06 11:10:02 EDT
(In reply to comment #16)
> Stopped working for me too with these:
> 
> NetworkManager-gtk-0.9.4-6.git20120521.fc16.i686
> NetworkManager-openconnect-0.9.0-3.fc16.i686
> NetworkManager-glib-0.9.4-6.git20120521.fc16.i686
> NetworkManager-pptp-0.9.0-1.fc16.i686
> NetworkManager-gnome-0.9.4-6.git20120521.fc16.i686
> NetworkManager-openvpn-0.9.0-1.fc16.i686
> NetworkManager-0.9.4-6.git20120521.fc16.i686
> NetworkManager-vpnc-0.9.0-1.fc16.i686
> 
> By default, there's no icon for nm-applet.
> 
> If I restart NetworkManager, the tray icon appears, but when I try to
> connect to a VPN connection, no dialog is displayed, and the following is
> logged in /var/log/messages:
> 
> Jun  6 10:16:56 localhost NetworkManager[2450]: <info> Starting VPN service
> 'vpnc'...
> Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN service 'vpnc'
> started (org.freedesktop.NetworkManager.vpnc), PID 2776
> Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN service 'vpnc'
> appeared; activating connections
> Jun  6 10:16:56 localhost NetworkManager[2450]: <info> VPN plugin state
> changed: init (1)
> Jun  6 10:16:56 localhost NetworkManager[2450]: <error> [1338970616.216254]
> [nm-vpn-connection.c:934] get_secrets_cb(): Failed to request VPN secrets
> #2: (6) No agents were available for this request.

If you get that message, nm-applet has likely crashed.  If you run 'nm-applet &' from a terminal then it should work again.  Regardless, that's a workaround to get up and running again, not a fix for the problem.
Comment 18 Dan Williams 2012-06-06 11:38:59 EDT
(In reply to comment #15)
> Oops, there were crashes of NM and nm-applet:
> 
> Jun  5 17:18:18 JBSX5R1 abrtd: Directory 'ccpp-2012-06-05-17:18:17-1030'
> creation detected
> Jun  5 17:18:18 JBSX5R1 abrt[18814]: Saved core dump of pid 1030
> (/usr/sbin/NetworkManager) to /var/spool/abrt/ccpp-2012-06-05-17:18:17-1030
> (27246592 bytes)

The NM crash looks like it was a crash on shutdown of NM from 'service NetworkManager restart' or 'systemctl restart NetworkManager.service', which obviously shouldn't be happening, but we also don't expect NM to be restarted during the normal course of events...  So it may not be a runtime crash.

But on F16, GNOME Shell doesn't handle the VPN passwords yet, so we need nm-applet still around for that.  *But* there's a dbus-glib bug which causes nm-applet to crash periodically when NM gets restarted for whatever reason.  You'll also see that periodically when GNOME shell flickers and respawns due to an NM restart.  So what *might* be happening in Marianne's case is that some restart of NM caused the dbus-glib bug, which causes nm-applet to crash, which means there's nothing to handle the VPN passwords becuase the applet doesn't get respawned by anything.
Comment 19 Jirka Klimes 2012-06-07 08:22:09 EDT
*** Bug 829258 has been marked as a duplicate of this bug. ***
Comment 20 Jirka Klimes 2012-06-07 08:23:51 EDT
*** Bug 826365 has been marked as a duplicate of this bug. ***
Comment 21 Phil Clayton 2012-06-07 09:16:55 EDT
Created attachment 590197 [details]
/var/log/messages

Since applying the latest F16 updates yesterday, including NetworkManager-0.9.4-6.git20120521.fc16.x86_64, NetworkManager fails to start properly _every_ boot.  (FWIW I always boot to multi-user.target and manually switch to graphical.target.)  As others point out, 'systemctl restart NetworkManager.service' brings back NM.

Full /var/log/messages (from latest boot) is attached.  debuginfo packages were installed but didn't appear to add much to the log.

[pclayton@rizzo tmp]$ sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 26
Policy from config file:        targeted

'ausearch -m avc' doesn't report any relevant issues: last entry is yesterday.  I have booted about 5 times today.

[pclayton@rizzo tmp]$ ps aux | grep NetworkManager
root      1128  0.0  0.0 269852  5860 ?        Ssl  13:45   0:00 /usr/sbin/NetworkManager --no-daemon
pclayton  2837  0.0  0.0 109252   932 pts/1    S+   14:10   0:00 grep --color=auto NetworkManager

[pclayton@rizzo tmp]$ ps aux | grep dbus
dbus      1694  0.0  0.0  30992  2864 ?        Ssl  13:46   0:00 /bin/dbus-daemon --system --address=systemd: --nofork --systemd-activation
pclayton  1911  0.0  0.0  22360   616 ?        S    13:46   0:00 dbus-launch --sh-syntax --exit-with-session
pclayton  1912  0.0  0.0  32232  2596 ?        Ssl  13:46   0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
pclayton  2840  0.0  0.0 109252   928 pts/1    S+   14:10   0:00 grep --color=auto dbus
Comment 22 Graeme Frear 2012-06-12 09:42:09 EDT
Created attachment 591193 [details]
Xsession-errors
Comment 23 Graeme Frear 2012-06-12 09:44:07 EDT
Created attachment 591195 [details]
From update to shutdown
Comment 24 Graeme Frear 2012-06-12 09:48:55 EDT
OK sorry for the spam. I also had the same problem yesterday, I've downgraded the packages but my dropdown vpnc is still broken.

Nothing interesting from ausearch, I've included xsession/varlog messages, not sure if it'll add anything of interest since I didn't have debugging activated.

Just in case, I'll add this
[gfrear@stardrive tmp]$ sestatus
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 26
Policy from config file:        targeted
Comment 25 Terry Bowling 2012-06-18 08:14:34 EDT
This issue has reared its ugly head for me again.  After an yum update on 6/16, my NetworkManager and nm-applet are no longer working again.  None of the network manager related packages were updated.  The list of packages updated are at the bottom of this comment.

The issue is not that nm-applet is crashing because that process is still running.  But when I lauch the NetworkManager GUI, there are NO settings there of my em1 interface, wireless access points or vpn profiles.  The nm-applet is running, so it is not that it is simply crashing.

When launching nm-applet and nm-connection-editor from the console, the following errors are generated:

------------------------------
$ nm-connection-editor 

** (nm-connection-editor:370): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist


** (nm-connection-editor:370): WARNING **: fetch_connections_done: error fetching connections: (19) Method "ListConnections" with signature "" on interface "org.freedesktop.NetworkManager.Settings" doesn't exist

------------------------------
$ nm-applet

** (nm-applet:1264): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

** Message: applet now removed from the notification area

** (nm-applet:1264): WARNING **: fetch_connections_done: error fetching connections: (19) Method "ListConnections" with signature "" on interface "org.freedesktop.NetworkManager.Settings" doesn't exist.

** (nm-applet:1264): WARNING **: Failed to register as an agent: (19) Method "Register" with signature "s" on interface "org.freedesktop.NetworkManager.AgentManager" doesn't exist


Packages updated on 6/16 from /var/log/yum.log
Jun 16 10:40:03 Updated: krb5-libs-1.9.3-2.fc16.x86_64
Jun 16 10:40:04 Updated: postgresql-libs-9.1.4-1.fc16.x86_64
Jun 16 10:40:05 Updated: gettext-libs-0.18.1.1-9.1.fc16.x86_64
Jun 16 10:40:06 Updated: python-virtinst-0.600.1-2.fc16.noarch
Jun 16 10:40:06 Updated: 32:bind-license-9.8.3-2.P1.fc16.noarch
Jun 16 10:40:06 Updated: 32:bind-libs-9.8.3-2.P1.fc16.x86_64
Jun 16 10:40:07 Updated: virt-manager-common-0.9.1-3.fc16.noarch
Jun 16 10:40:10 Updated: gettext-0.18.1.1-9.1.fc16.x86_64
Jun 16 10:40:13 Updated: postgresql-9.1.4-1.fc16.x86_64
Jun 16 10:40:14 Updated: sssd-client-1.8.4-13.fc16.x86_64
Jun 16 10:40:14 Updated: gettext-common-devel-0.18.1.1-9.1.fc16.noarch
Jun 16 10:40:14 Updated: libipa_hbac-1.8.4-13.fc16.x86_64
Jun 16 10:40:14 Updated: libreport-filesystem-2.0.10-3.fc16.x86_64
Jun 16 10:40:15 Updated: libreport-python-2.0.10-3.fc16.x86_64
Jun 16 10:40:16 Updated: libreport-2.0.10-3.fc16.x86_64
Jun 16 10:40:16 Updated: 2:vim-filesystem-7.3.515-2.fc16.x86_64
Jun 16 10:40:19 Updated: 2:vim-common-7.3.515-2.fc16.x86_64
Jun 16 10:40:20 Updated: gnutls-2.12.14-3.fc16.x86_64
Jun 16 10:40:26 Updated: 1:java-1.6.0-openjdk-1.6.0.0-67.1.11.3.fc16.x86_64
Jun 16 10:40:28 Updated: 1:java-1.6.0-openjdk-devel-1.6.0.0-67.1.11.3.fc16.x86_64
Jun 16 10:40:29 Updated: gnutls-utils-2.12.14-3.fc16.x86_64
Jun 16 10:40:41 Updated: 2:vim-X11-7.3.515-2.fc16.x86_64
Jun 16 10:40:42 Updated: 2:vim-enhanced-7.3.515-2.fc16.x86_64
Jun 16 10:40:43 Updated: libreport-plugin-kerneloops-2.0.10-3.fc16.x86_64
Jun 16 10:40:44 Updated: libreport-gtk-2.0.10-3.fc16.x86_64
Jun 16 10:40:44 Updated: libreport-plugin-bugzilla-2.0.10-3.fc16.x86_64
Jun 16 10:40:45 Updated: libreport-plugin-logger-2.0.10-3.fc16.x86_64
Jun 16 10:40:45 Updated: libreport-plugin-bodhi-2.0.10-3.fc16.x86_64
Jun 16 10:40:47 Updated: libreport-newt-2.0.10-3.fc16.x86_64
Jun 16 10:40:51 Updated: sssd-1.8.4-13.fc16.x86_64
Jun 16 10:40:52 Updated: gettext-devel-0.18.1.1-9.1.fc16.x86_64
Jun 16 10:40:55 Updated: postgresql-server-9.1.4-1.fc16.x86_64
Jun 16 10:40:56 Updated: virt-manager-0.9.1-3.fc16.noarch
Jun 16 10:40:57 Updated: 32:bind-utils-9.8.3-2.P1.fc16.x86_64
Jun 16 10:40:58 Updated: 32:bind-libs-lite-9.8.3-2.P1.fc16.x86_64
Jun 16 10:40:59 Updated: krb5-workstation-1.9.3-2.fc16.x86_64
Jun 16 10:40:59 Updated: python-httplib2-0.7.4-2.fc16.noarch
Jun 16 10:41:01 Updated: kernel-headers-3.3.8-1.fc16.x86_64
Jun 16 10:41:02 Updated: 1:microcode_ctl-1.17-25.fc16.x86_64
Jun 16 10:41:03 Updated: perl-Locale-Codes-3.22-1.fc16.noarch
Jun 16 10:41:04 Updated: 2:vim-minimal-7.3.515-2.fc16.x86_64
Jun 16 10:41:37 Updated: 1:java-1.6.0-openjdk-javadoc-1.6.0.0-67.1.11.3.fc16.x86_64
Jun 16 10:41:49 Installed: kernel-devel-3.3.8-1.fc16.x86_64
Jun 16 10:42:03 Updated: kernel-doc-3.3.8-1.fc16.noarch
Jun 16 10:42:09 Installed: kernel-3.3.8-1.fc16.x86_64
Jun 16 10:42:11 Updated: krb5-libs-1.9.3-2.fc16.i686
Comment 26 Jirka Klimes 2012-06-25 05:36:14 EDT
*** Bug 833108 has been marked as a duplicate of this bug. ***
Comment 27 Eric Smith 2012-06-25 19:36:11 EDT
I just encountered what appears to be the same bug (certainly the same symptoms) with F17.  If I change /etc/sysconfig/selinux to set SELINUX=permissive (instead of enforcing), then the NM applet works correctly.

I think this broke when I did an update that installed selinux-policy{,-devel,-targeted}-3.10.0-132, although I have not tried reverting to -128 to test that hypothesis.
Comment 28 Jirka Klimes 2012-06-26 07:36:32 EDT
(In reply to comment #27)
> I just encountered what appears to be the same bug (certainly the same
> symptoms) with F17.  If I change /etc/sysconfig/selinux to set
> SELINUX=permissive (instead of enforcing), then the NM applet works
> correctly.
> 
> I think this broke when I did an update that installed
> selinux-policy{,-devel,-targeted}-3.10.0-132, although I have not tried
> reverting to -128 to test that hypothesis.

That will probably be another issue. Nonetheless, do you see an SELinux error related to NM?

# ausearch -m avc -ts today
# ausearch -m avc
Comment 29 stajem 2012-06-27 12:39:35 EDT
I have the same bug.
I use "killall NetworkManager && NetworkManager" at every boot...

If you need more informations...
Comment 30 Terry Bowling 2012-07-01 09:42:59 EDT
Confirmed, does not appear to be selinux related.  I find no errors or warnings, nor does permissive mode resolve the issue.

I'm wondering if it could be a sequence/order issue of when network manager starts up.

I am successfully using this work around:

#   sudo service NetworkManager restart

then as regular user
#   nm-applet &

A little more elegant than killall, but I still have to do it after every reboot (which is not often).

Sorry I don't have more time to debug.  Is this confirmed to be occurring in F17?
Comment 31 Jirka Klimes 2012-07-10 08:04:39 EDT

*** This bug has been marked as a duplicate of bug 817851 ***

Note You need to log in before you can comment on or make changes to this bug.