Bug 833108 - network manager vpnc stopped working
network manager vpnc stopped working
Status: CLOSED DUPLICATE of bug 826706
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 11:13 EDT by Vivek Goyal
Modified: 2012-06-25 05:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 05:36:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Goyal 2012-06-18 11:13:58 EDT
Description of problem:

I have vpnc confirued through network manager and usually I just had to click the respective icon "ON". Now trying to establish vpn connection that way does not do anything. 

I see following messages in /var/log/messages.

**********************************************************************
Jun 18 11:06:38 horse NetworkManager[2482]: <info> Starting VPN service 'vpnc'...
Jun 18 11:06:38 horse NetworkManager[2482]: <info> VPN service 'vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 7973
Jun 18 11:06:38 horse NetworkManager[2482]: <info> VPN service 'vpnc' appeared; activating connections
Jun 18 11:06:38 horse NetworkManager[2482]: <info> VPN plugin state changed: init (1)
Jun 18 11:06:38 horse NetworkManager[2482]: <error> [1340031998.365051] [nm-vpn-connection.c:934] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Jun 18 11:06:38 horse NetworkManager[2482]: <info> Policy set 'System em1' (em1) as default for IPv4 routing and DNS.
Jun 18 11:06:43 horse NetworkManager[2482]: <info> VPN service 'vpnc' disappeared
*****************************************************************************

Any idea what's happening?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vivek Goyal 2012-06-18 11:27:37 EDT
For some reason nm-applet crashes on boot and it was not running. I ran nm-applet and now vpnc seems to work.

nm-applet &

After boot, NetworkManager icon was not present at all on upper right hand corner. Then I restarted NetworkManager and icon appeared. Then abrt also kicked in saying nm-applet had crashed.

So one problem point definitely seems to be nm-applet.
Comment 2 Jirka Klimes 2012-06-25 05:36:14 EDT

*** This bug has been marked as a duplicate of bug 826706 ***

Note You need to log in before you can comment on or make changes to this bug.