Bug 826739 - My Subscriptions Tab - Combine Service Level and Service Type Fields in Subscription Details Pane
My Subscriptions Tab - Combine Service Level and Service Type Fields in Subsc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
: 826742 (view as bug list)
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-30 16:59 EDT by Matt Reid
Modified: 2013-01-07 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
combined service-level and type fields (90.01 KB, image/png)
2012-08-22 05:14 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Matt Reid 2012-05-30 16:59:39 EDT
Description of problem:
Even in the default window size of Sub Man, we are under utilizing horizontal space in the Subscription Details pane, and creating more vertical scrolling for users.

I don't think we need to list Service Level and Service Type separately, and we could combine that display into one field, "Service Level, Type". This would eliminate an extra row and still leave us with plenty of space before needing to scroll the pane horizontally to see both listed. 

Service Level, Type: STANDARD, L1-L3

instead of

Service Level: STANDARD 
Service Type: L1-L3

Version:
sub-man 1.0.2-1.git.2.2b23e6e

Additional Info:
I think we can do the same for Start Date and End Date, see BZ 826735 for more info.

If we do this, we should carry it over to the Subscription Details pane in All Available Subscriptions as well, I'll file a BZ.
Comment 1 Alex Wood 2012-06-26 16:43:07 EDT
*** Bug 826742 has been marked as a duplicate of this bug. ***
Comment 2 Alex Wood 2012-06-26 16:46:05 EDT
Matt,

What would you like the behavior to be when the service level is an empty string?  It looks a little strange to have the screen displaying

Service Level, Type: , L1-L3
Comment 3 Bryan Kearney 2012-08-14 18:50:12 EDT
Alex, can you pick up 827553 as part of this?
Comment 4 Bryan Kearney 2012-08-14 18:51:58 EDT
Alex, I vote 'Not Set , L1-L3'

-- bk
Comment 5 Alex Wood 2012-08-16 09:24:31 EDT
commit e8118cdd96ccf616f8e94801cba4e80a373ec189
Refs: <origin/awood/826739>, awood/826739, subscription-manager-1.0.13-1-31-ge8118cd
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Wed Aug 15 17:13:53 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Wed Aug 15 17:19:12 2012 -0400

    826739, 827553: Combine Service Level and Service Type and move up in display order.

The service level will be displayed as "Not Set" when it is an empty string.
Comment 6 RHEL Product and Program Management 2012-08-17 14:38:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 8 Shwetha Kallesh 2012-08-22 05:14:55 EDT
Created attachment 606181 [details]
combined service-level and type fields

[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.14-1.git.10.4cd750a.el5
subscription-manager-1.0.14-1.git.10.4cd750a.el5
Comment 10 errata-xmlrpc 2013-01-07 22:53:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.