Bug 826753 - SELinux is preventing /usr/sbin/chronyd from 'search' accesses on the directory samba.
SELinux is preventing /usr/sbin/chronyd from 'search' accesses on the directo...
Status: CLOSED DUPLICATE of bug 826751
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bbbadc2aeb84d4469712b92c3a4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 18:17 EDT by sahinsureyya
Modified: 2012-05-31 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 13:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sahinsureyya 2012-05-30 18:17:14 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 30 May 2012 06:16:38 PM EDT

description:
:SELinux is preventing /usr/sbin/chronyd from 'search' accesses on the directory samba.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chronyd should be allowed search access on the samba directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chronyd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:chronyd_t:s0
:Target Context                system_u:object_r:samba_etc_t:s0
:Target Objects                samba [ dir ]
:Source                        chronyd
:Source Path                   /usr/sbin/chronyd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           chrony-1.27-0.3.pre1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 30 May 2012 06:01:09 PM EDT
:Last Seen                     Wed 30 May 2012 06:01:09 PM EDT
:Local ID                      c63b7e79-9315-417d-8897-e87dc700e943
:
:Raw Audit Messages
:type=AVC msg=audit(1338415269.613:20): avc:  denied  { search } for  pid=676 comm="chronyd" name="samba" dev="dm-0" ino=1205678 scontext=system_u:system_r:chronyd_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1338415269.613:20): avc:  denied  { getattr } for  pid=676 comm="chronyd" path="/etc/samba/smb.conf" dev="dm-0" ino=1205680 scontext=system_u:system_r:chronyd_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338415269.613:20): arch=x86_64 syscall=stat success=yes exit=0 a0=7f2968eefaa0 a1=7fff60ad7cb0 a2=7fff60ad7cb0 a3=7fff60ad7a40 items=0 ppid=1 pid=676 auid=4294967295 uid=994 gid=992 euid=994 suid=994 fsuid=994 egid=992 sgid=992 fsgid=992 tty=(none) ses=4294967295 comm=chronyd exe=/usr/sbin/chronyd subj=system_u:system_r:chronyd_t:s0 key=(null)
:
:Hash: chronyd,chronyd_t,samba_etc_t,dir,search
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-31 13:51:01 EDT

*** This bug has been marked as a duplicate of bug 826751 ***

Note You need to log in before you can comment on or make changes to this bug.