Bug 826751 - SELinux is preventing /usr/sbin/sendmail.sendmail from 'read' accesses on the file smb.conf.
SELinux is preventing /usr/sbin/sendmail.sendmail from 'read' accesses on the...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:15a8aba5a185ceb4313f71ae0ca...
:
: 826619 826753 826755 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 18:09 EDT by sahinsureyya
Modified: 2012-06-16 20:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-16 20:00:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sahinsureyya 2012-05-30 18:09:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 30 May 2012 06:07:29 PM EDT

description:
:SELinux is preventing /usr/sbin/sendmail.sendmail from 'read' accesses on the file smb.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that sendmail.sendmail should be allowed read access on the smb.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sendmail /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sendmail_t:s0
:Target Context                system_u:object_r:samba_etc_t:s0
:Target Objects                smb.conf [ file ]
:Source                        sendmail
:Source Path                   /usr/sbin/sendmail.sendmail
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           sendmail-8.14.5-12.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 30 May 2012 06:01:10 PM EDT
:Last Seen                     Wed 30 May 2012 06:01:14 PM EDT
:Local ID                      fa9be188-d89e-4063-b65f-cdbb363b28a4
:
:Raw Audit Messages
:type=AVC msg=audit(1338415274.630:55): avc:  denied  { read } for  pid=1008 comm="sendmail" name="smb.conf" dev="dm-0" ino=1205680 scontext=system_u:system_r:sendmail_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=AVC msg=audit(1338415274.630:55): avc:  denied  { open } for  pid=1008 comm="sendmail" name="smb.conf" dev="dm-0" ino=1205680 scontext=system_u:system_r:sendmail_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338415274.630:55): arch=x86_64 syscall=open success=yes exit=EINTR a0=7f772537ed80 a1=0 a2=0 a3=78 items=0 ppid=1 pid=1008 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=51 sgid=51 fsgid=51 tty=(none) ses=4294967295 comm=sendmail exe=/usr/sbin/sendmail.sendmail subj=system_u:system_r:sendmail_t:s0 key=(null)
:
:Hash: sendmail,sendmail_t,samba_etc_t,file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-31 13:51:01 EDT
*** Bug 826753 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2012-05-31 13:52:21 EDT
Fixed in selinux-policy-3.10.0-129.fc17

All apps that call getpw will be allowed to read /etc/samba content.
Comment 3 Daniel Walsh 2012-05-31 13:52:32 EDT
*** Bug 826755 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2012-05-31 13:53:27 EDT
*** Bug 826619 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-06-11 16:58:21 EDT
selinux-policy-3.10.0-130.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-130.fc17
Comment 6 Fedora Update System 2012-06-15 19:56:09 EDT
Package selinux-policy-3.10.0-130.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-130.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9520/selinux-policy-3.10.0-130.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-16 20:00:59 EDT
selinux-policy-3.10.0-130.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.