Bug 826755 - SELinux is preventing /usr/sbin/rsyslogd from 'getattr' accesses on the file /etc/samba/smb.conf.
SELinux is preventing /usr/sbin/rsyslogd from 'getattr' accesses on the file ...
Status: CLOSED DUPLICATE of bug 826751
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5b191894d278072529fe9f0fa44...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 18:20 EDT by sahinsureyya
Modified: 2012-05-31 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 13:52:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sahinsureyya 2012-05-30 18:20:27 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 30 May 2012 06:19:49 PM EDT

description:
:SELinux is preventing /usr/sbin/rsyslogd from 'getattr' accesses on the file /etc/samba/smb.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rsyslogd should be allowed getattr access on the smb.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rsyslogd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:syslogd_t:s0
:Target Context                system_u:object_r:samba_etc_t:s0
:Target Objects                /etc/samba/smb.conf [ file ]
:Source                        rsyslogd
:Source Path                   /usr/sbin/rsyslogd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           rsyslog-5.8.10-1.fc17.x86_64
:Target RPM Packages           samba-common-3.6.5-86.fc17.1.x86_64
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Wed 30 May 2012 06:01:09 PM EDT
:Last Seen                     Wed 30 May 2012 06:18:12 PM EDT
:Local ID                      1c23af7f-9314-4bc0-ade1-915e4817cacb
:
:Raw Audit Messages
:type=AVC msg=audit(1338416292.231:27): avc:  denied  { getattr } for  pid=695 comm="rsyslogd" path="/etc/samba/smb.conf" dev="dm-0" ino=1205680 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338416292.231:27): arch=x86_64 syscall=stat success=yes exit=0 a0=7f5a9ac1f7a0 a1=7fffb1d91c80 a2=7fffb1d91c80 a3=7fffb1d91a10 items=0 ppid=1 pid=695 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rsyslogd exe=/usr/sbin/rsyslogd subj=system_u:system_r:syslogd_t:s0 key=(null)
:
:Hash: rsyslogd,syslogd_t,samba_etc_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-31 13:52:32 EDT

*** This bug has been marked as a duplicate of bug 826751 ***

Note You need to log in before you can comment on or make changes to this bug.