Bug 827045 - SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'read' accesses on the file /home/ksekera/.local/share/icc/edid-b929974f562dd5320979a8212d8b987a.icc.
SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'read' accesses on ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:09458d4bee4d7a07523e590d5c8...
:
: 827105 827182 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 10:06 EDT by klement.sekera
Modified: 2012-07-21 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-21 18:51:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klement.sekera 2012-05-31 10:06:58 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.x86_64
time:           Thu 31 May 2012 04:06:33 PM CEST

description:
:SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'read' accesses on the file /home/ksekera/.local/share/icc/edid-b929974f562dd5320979a8212d8b987a.icc.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/ksekera/.local/share/icc/edid-b929974f562dd5320979a8212d8b987a.icc default label should be icc_data_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/ksekera/.local/share/icc/edid-b929974f562dd5320979a8212d8b987a.icc
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that dbus-daemon (deleted) should be allowed read access on the edid-b929974f562dd5320979a8212d8b987a.icc file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:ecryptfs_t:s0
:Target Objects                /home/ksekera/.local/share/icc/edid-
:                              b929974f562dd5320979a8212d8b987a.icc [ file ]
:Source                        dbus-daemon
:Source Path                   /usr/bin/dbus-daemon (deleted)
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.x86_64 #1 SMP
:                              Mon May 7 17:29:34 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Thu 31 May 2012 04:02:39 PM CEST
:Last Seen                     Thu 31 May 2012 04:05:12 PM CEST
:Local ID                      ee84eb2a-bdca-4b17-8c92-88f217d8ab02
:
:Raw Audit Messages
:type=AVC msg=audit(1338473112.347:579): avc:  denied  { read } for  pid=624 comm="dbus-daemon" path="/home/ksekera/.local/share/icc/edid-b929974f562dd5320979a8212d8b987a.icc" dev="ecryptfs" ino=7995555 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:ecryptfs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338473112.347:579): arch=x86_64 syscall=recvmsg success=yes exit=413 a0=19 a1=7fff5f30fa60 a2=40000000 a3=0 items=0 ppid=1 pid=624 auid=4294967295 uid=81 gid=81 euid=81 suid=81 fsuid=81 egid=81 sgid=81 fsgid=81 tty=(none) ses=4294967295 comm=dbus-daemon exe=2F7573722F62696E2F646275732D6461656D6F6E202864656C6574656429 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,system_dbusd_t,ecryptfs_t,file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-31 13:40:24 EDT
Is your entire homedir labeled encryptfs_t?

ls -lZ /home/ksekera
Comment 2 klement.sekera 2012-06-01 02:35:30 EDT
[ksekera@ksekera-fedora ~]$ ls -lZ /home | grep ksekera
drwx------. ksekera ksekera system_u:object_r:ecryptfs_t:s0  ksekera
Comment 3 Miroslav Grepl 2012-06-04 11:07:32 EDT
*** Bug 827105 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-06-04 11:16:47 EDT
Could try to do the following steps


1. Download this attachment

https://bugzilla.redhat.com/attachment.cgi?id=534831

2. tar zxfv ecrypt.tgz
3. cd ecrypt/
4. sh ecrypt.sh <username>
5. setsebool -P use_ecryptfs_home_dirs 1


and re-test it. Thank you.
Comment 5 Miroslav Grepl 2012-06-04 11:25:34 EDT
*** Bug 827182 has been marked as a duplicate of this bug. ***
Comment 6 klement.sekera 2012-06-04 12:12:00 EDT
I'm sorry, but I don't have the environment(s) anymore. I need a working setup, so I abandoned ecryptfs and replaced it with a luks encrypted /home.

So I am unable to test your changes. However, I believe this bug will occur on any platform.
Comment 7 Miroslav Grepl 2012-06-22 07:10:15 EDT
We added fixes to rawhide which I will backport.
Comment 8 Miroslav Grepl 2012-07-15 16:05:35 EDT
Fixed in selinux-policy-3.10.0-139.fc17
Comment 9 Fedora Update System 2012-07-18 09:03:50 EDT
selinux-policy-3.10.0-140.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-140.fc17
Comment 10 Fedora Update System 2012-07-19 05:10:45 EDT
Package selinux-policy-3.10.0-140.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-140.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10840/selinux-policy-3.10.0-140.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-07-21 18:51:04 EDT
selinux-policy-3.10.0-140.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.