Bug 827087 - Package sisu-cglib should not be built for RHEL6.x with a dependency on ant > 1.7.1
Package sisu-cglib should not be built for RHEL6.x with a dependency on ant >...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.0.1
Unspecified Unspecified
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: Jesus M. Rodriguez
Garik Khachikyan
: Triaged
Depends On:
Blocks: 827094
  Show dependency treegraph
 
Reported: 2012-05-31 11:00 EDT by Eric Sammons
Modified: 2015-01-04 16:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The sisu-cglib package specification file had an incorrect runtime requirement of ant >= 1.8.3. This caused the ant package to upgrade unnecessarily and result in dependency conflicts with other packages. This issue is resolved in the latest CloudForms System Engine release since the ant package is not installed anymore.
Story Points: ---
Clone Of:
: 827094 (view as bug list)
Environment:
Last Closed: 2012-12-04 14:46:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-05-31 11:00:26 EDT
Description of problem:
Current issues have surfaced due to requirements specified in the current version of sisu-cglib. 

Requires: ant >= 0:1.8.3
BuildRequires: ant >= 1.8.3

Per the upstream ant is not a runtime requirement and per my testing BuildRequires ant 1.7.1 will suffice.  The issue here is by reving ant up in SAM we are essentially rebasing ant in RHEL6.  This causes issues of dependencies on 1.7.1 not being satisfied and then sam-1.1 not upgrading because of its dependencies on ant-1.8.3 due to sisu-cglib.

We should not be rebasing packages in a version of RHEL and we should not be rebasing a package provide in the rhel-server channel with a package from a add-on channel.

Version-Release number of selected component (if applicable):
sisu-cglib-2.2.2-1.2

Updated packages have been built here:
https://brewweb.devel.redhat.com/taskinfo?taskID=4467217
Comment 1 Eric Sammons 2012-05-31 12:07:32 EDT
# diff sisu-cglib.spec /tmp/sisu-cglib.spec 
52d51
< Requires:       ant >= 0:1.8.2
62c61
< BuildRequires:  ant >= 0:1.8.2
---
> BuildRequires:  ant >= 0:1.7.1
Comment 2 Eric Sammons 2012-05-31 12:07:55 EDT
Created a JIRA case also.

https://issues.jboss.org/browse/JBPAPP-9207
Comment 3 Mike McCune 2012-08-03 13:12:11 EDT
this is a candlepin issue.  Assigning to Jesus
Comment 6 Garik Khachikyan 2012-09-17 07:11:10 EDT
# VERIFIED

Checked on recent provided puddle: 

ant package is not getting installed at all. Also --requires does not show any ant there.

checked against:
----

katello-glue-candlepin-1.1.12-7.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
qpid-cpp-server-0.14-16.el6.x86_64
katello-cli-common-1.1.8-4.el6cf.noarch
qpid-cpp-server-ssl-0.14-16.el6.x86_64
katello-certs-tools-1.1.8-1.el6cf.noarch
candlepin-0.7.8-1.el6cf.noarch
katello-common-1.1.12-7.el6cf.noarch
qpid-cpp-client-0.14-16.el6.x86_64
katello-1.1.12-7.el6cf.noarch
katello-cli-1.1.8-4.el6cf.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.1.9-3.el6cf.noarch
candlepin-tomcat6-0.7.8-1.el6cf.noarch
katello-selinux-1.1.1-1.el6cf.noarch
pulp-common-1.1.12-1.el6cf.noarch
katello-all-1.1.12-7.el6cf.noarch
qpid-cpp-client-ssl-0.14-16.el6.x86_64
python-qpid-0.14-8.el6.noarch
candlepin-selinux-0.7.8-1.el6cf.noarch
pulp-selinux-server-1.1.12-1.el6cf.noarch
pulp-1.1.12-1.el6cf.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
katello-glue-pulp-1.1.12-7.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Comment 9 errata-xmlrpc 2012-12-04 14:46:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2012-1543.html
Comment 10 Mike McCune 2013-08-16 14:18:28 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.