Bug 827094 - Package sisu-cglib should not be built for RHEL6.x with a dependency on ant > 1.7.1
Package sisu-cglib should not be built for RHEL6.x with a dependency on ant >...
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: rel-eng (Show other bugs)
1.0.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
: Triaged
Depends On: 827087
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 11:15 EDT by Eric Sammons
Modified: 2014-11-09 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 827087
Environment:
Last Closed: 2012-08-22 13:00:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-05-31 11:15:50 EDT
+++ This bug was initially created as a clone of Bug #827087 +++

Description of problem:
Current issues have surfaced due to requirements specified in the current version of sisu-cglib. 

Requires: ant >= 0:1.8.3
BuildRequires: ant >= 1.8.3

Per the upstream ant is not a runtime requirement and per my testing BuildRequires ant 1.7.1 will suffice.  The issue here is by reving ant up in SAM we are essentially rebasing ant in RHEL6.  This causes issues of dependencies on 1.7.1 not being satisfied and then sam-1.1 not upgrading because of its dependencies on ant-1.8.3 due to sisu-cglib.

We should not be rebasing packages in a version of RHEL and we should not be rebasing a package provide in the rhel-server channel with a package from a add-on channel.

Version-Release number of selected component (if applicable):
sisu-cglib-2.2.2-1.2

Updated packages have been built here:
https://brewweb.devel.redhat.com/taskinfo?taskID=4467217
Comment 1 Eric Sammons 2012-05-31 12:06:26 EDT
# diff sisu-cglib.spec /tmp/sisu-cglib.spec 
52d51
< Requires:       ant >= 0:1.8.2
62c61
< BuildRequires:  ant >= 0:1.8.2
---
> BuildRequires:  ant >= 0:1.7.1
Comment 2 Eric Sammons 2012-05-31 12:08:47 EDT
Created a JIRA case also.

https://issues.jboss.org/browse/JBPAPP-9207
Comment 3 Eric Sammons 2012-06-06 14:49:00 EDT
This requirement has been removed.

Note You need to log in before you can comment on or make changes to this bug.