Bug 82711 - installer can not handle multiple scsi CDROM drives
installer can not handle multiple scsi CDROM drives
Status: CLOSED DUPLICATE of bug 74719
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-25 00:38 EST by Need Real Name
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-01-25 00:38:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030124

Description of problem:
Hi All,

     I have a Red Hat 7.0 server with eight (8) Toshiba XM6401 SCSI-2 
CD-ROM drives, an AdvanSys ABP3980UA, 4 channel PCI SCSI-2 
Controller, and an AMI MegaRAID Express 500 Controller.  The
CD-ROM drives are connected to two channels on the AdvanSys card.
Hard drives are connected the AMI card.

   When I attempted to upgrade a Red Hat 7.0 server to
Red Hat 8.0, I got the following message:

            Probing for mouse type: xxxx
            traceback (most recent call first):

            File "/usr/bin/anaconda", Line 639 in ?
            iutil.makeDriveDeviceNodes()

            File "/usr/bin/anaconda/iutil.py", Line 420 in ?
            iutil.makeDriveDeviceNodes
            isys.makeDevInode (drive, "/dev/%s" % (drive,))

            File "/usr/bin/anaconda/isys.py", line 265,
            in makeDevInode  _isys,mkdevinode (name,fn)

            System Error: (2, 'no such file or directory')
            install exited abnormally

   In the process of troubleshooting, I replaced the AdvanSys card with a
single channel Adaptec AHA-2940 card.  As it is a single channel card
and I have a tape drive on the bus, I had to reduce the CD-ROM drive
count from seven to five.  The symptom was identical.

   Now here is the catch.  If I power off all but one of the CD-ROM drives,
the install works.  (I powering them back on after the install and they
worked perfectly.)

--Tony

My configuration:

      MSI MS-6120 Dual Pentium II ATX Motherboard w/o SCSI
      Intel Pentium III 600E MHz  (box) (qty=2)
      Matrox Millennium G400-AGP, 64-bit graphics board with 16 Meg SGRAM
      Toshiba XM6401 40X SCSI CD-ROM Drive  (qty=8, Note: reduced to 6)
      AdvanSys ABP3980UA, 4 channel PCI SCSI-2 Controller
             Note: replaced with an Adapted AHA 2940
      Viewsonic GS773, 17 " (16" viewable) Short Depth Monitor
      Teac 1.44 MB, 3= inch floppy disk drive
      Ecrix VXA-1, 50 pin SCSI Internal Tape Drive w/ White Bezel
      Ecrix VXA-1 Cleaning Tape
      Ecrix VXA-1 V6, 12/24 Data Cartridge (qty=15)
      AMI 4751010232A, MegaRAID Express 500 
      Fuji MAH3182MP, 7200 rpm, 18.2 GB SCSI-U2 Hard Drive (qty=4)
      Adaptec 1729600, 9 Connector 68 Pin Internal Ultra 160 SCSI Cable w/
Terminator
      Microsoft Wheel Mouse Optical
      Antec  SX1030 SOHO File Server case with two rear fansKingston 
      KNE100TX 10/100               Ethernet Adapter (qty=2)
      14' RJ45 Category 5 Patch Cable - Gray (qty=2)
      6' RJ45 Category 5 Patch Cable - Gray (qty=2)
      Eicon Diva Lan ISDN Modem 310-262-05
      Red Hat Linux V 7.0 Standard
      6' VGA Extension Cable
      6' ps/2 Extension Cable (Straight) (qty=2)
      128 Meg PC-133 ECC SDRAM Memory Modules
      Innovative BP802512M, .16A, 80x25 Ball Bearing Fan with 4 pin Connector

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  try installing it with 5 or more scsi2 cdrom drives
2.
3.
    

Additional info:
Comment 1 Need Real Name 2003-01-26 20:36:17 EST
   One thing just occured to me:  I never tested the problem with
all the cdrom drives fired up and the disks removed, except
the install disk.  The install may have been looking for files
on the wrong disk. 
Comment 2 Jeremy Katz 2003-01-28 20:56:25 EST
The update disk available at
http://people.redhat.com/~katzj/80update.img includes a fix for this problem

*** This bug has been marked as a duplicate of 74719 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.