Bug 827119 - Yumex fails to open /bin/yumex.glade
Yumex fails to open /bin/yumex.glade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 840663 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 12:38 EDT by My Karlsson
Modified: 2012-08-24 23:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 22:57:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description My Karlsson 2012-05-31 12:38:35 EDT
Description of problem:

Yumex fails to launch due to not being able to find /bin/yumex.glade.

Version-Release number of selected component (if applicable):

yumex-3.0.5-2.fc17.noarch

How reproducible:


Steps to Reproduce:
1. yum install yumex
2. yumex
  
Actual results:

** (process:30921): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:30921): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:30921): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/bin/yumex", line 42, in <module>
    app = YumexApplication(backend)
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 203, in __init__
    Controller.__init__(self, BUILDER_FILE , 'main', domain='yumex')
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 278, in __init__
    self.ui = UI(filename, rootname, domain)
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 256, in __init__
    self.add_from_file(filename)
GError: Failed to open file '/bin/yumex.glade': No such file or directory


And then the program quits

Expected results:

Yumex should successfully launch.

Additional info:

It seams like yumex.glade is located in /usr/share/yumex/yumex.glade, not under /bin.
Comment 1 Christian Ziemski 2012-05-31 16:17:36 EDT
That one hit me too today - after an "yum update" a couple of hours after the initial install of F17.

Not a solution, but downgrading to yumex-3.0.4 helps.

Christian
Comment 2 Felix Miata 2012-06-04 23:03:00 EDT
Hit me, but I hadn't tried to install it until 3.0.5 was available. 3.0.4 works.
Comment 3 Tim Lauridsen 2012-06-06 08:20:09 EDT
how does your path look like ?

echo $PATH

If you have /bin before /usr/bin in your path you will get this issue

because in F17 /bin is just a link to /usr/bin

yumex uses the path of the command to start yumex to detect where to find the glade file

if it starts with /usr/bin then /usr/share/yumex/yumex.glade is used
else the current directory of the starting command is used (normally the source dir of a git checkout)

yumex is normally installed as /usr/bin/yumex, but if /bin is in the path before /usr/bin then it fails.

step to reproduce:

/bin/yumex (will get this error)

/usr/bin/yumex (will works)
Comment 5 Felix Miata 2012-06-06 08:47:47 EDT
(In reply to comment #3)
> how does your path look like ?
> echo $PATH
> If you have /bin before /usr/bin in your path you will get this issue

/bin precedes /usr/bin, but not because of anything I did to change any F17 default.
Comment 6 Tim Lauridsen 2012-06-06 10:41:39 EDT
it must be the F17 clean install default, I have updated my F16 to F17 using preupgrade, so I had not detected the issue before.
Comment 7 Steven Usdansky 2012-06-23 10:44:36 EDT
F17 -> Rawhide system, fully updated except for yumex. 
Updated to yumex-3.0.5-2.fc18.noarch and applied the upstream fix at
https://github.com/timlau/yumex/commit/16b690d0cd59642008ba59ca7567140c9b35132a

Traceback (most recent call last):
  File "/bin/yumex", line 45, in <module>
    app.run()
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 260, in run
    self.setup_gui()
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 385, in setup_gui
    accel='<Ctrl>1')
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 479, in add_page
    self.selector.add_button(key, icon=icon, tooltip=tooltip, accel=accel)
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 150, in add_button
    pb = gtk.gdk.pixbuf_new_from_file(icon)
GError: Failed to open file '/usr/share/yumex/../gfx/button-packages.png': No such file or directory

Downgraded to yumex-3.0.4-1.fc17.noarch fixed the problem
Comment 8 Tim Lauridsen 2012-06-25 13:07:06 EDT
New and better fix here

https://github.com/timlau/yumex/commit/ca23769be6b94709d2a8c43b48e78d6caf50a0f0
Comment 9 Tim Lauridsen 2012-06-25 13:18:21 EDT
Test RPM available here:

http://timlau.fedorapeople.org/files/yumex/
Comment 10 Samuel Irlapati 2012-06-25 13:26:06 EDT
Tried the test rpm and it works for me.
Comment 11 Steven Usdansky 2012-06-26 16:06:46 EDT
Tried the test rpm and yumex froze as shown below:
~/.config$ yumex
15:02:16 : INFO - Using config file : /home/a/.config/yumex/yumex.conf
15:02:16 : INFO - Using config file : /home/a/.config/yumex/yumex.conf
15:02:17 : DEBUG - network interface wlan0 (ath9k_htc) is connected
15:02:17 : INFO - Connected to an network
15:02:17 : DEBUG - network interface wlan0 (ath9k_htc) is connected
15:02:17 : INFO - Starting yum child process
Updated Rawhide:
deltarpm-3.6-0.8.20110223git.fc18.x86_64
python-deltarpm-3.6-0.8.20110223git.fc18.x86_64
rpm-4.10.0-2.fc18.x86_64
rpm-build-libs-4.10.0-2.fc18.x86_64
rpm-libs-4.10.0-2.fc18.x86_64
rpmorphan-1.10-2.fc17.noarch
rpm-python-4.10.0-2.fc18.x86_64
yum-3.4.3-29.fc18.noarch
yumex-3.0.6-0.1.git20120625.fc17.noarch
yum-langpacks-0.2.5-1.fc18.noarch
yum-metadata-parser-1.1.4-6.fc17.x86_64
yum-presto-0.8.1-1.fc18.noarch
yum-utils-1.1.31-5.fc18.noarch
Comment 12 Tim Lauridsen 2012-06-27 00:39:25 EDT
@Steven:

Look like there is an issue with polkit & yumex in current rawhide.

https://bugzilla.redhat.com/show_bug.cgi?id=834494

Can you please test if the 2.0.5 in the repositories has the same issue and report it in the report above.
Comment 13 Steven Usdansky 2012-06-29 08:26:41 EDT
Currently running without problems: 
polkit-0.105-1.fc18.x86_64, yumex-3.0.6-0.1.git20120625.fc17.noarch

Everything still works when downgrading to yumex-3.0.5-2.fc18.noarch; looks like polkit is the culprit
Comment 14 Zdenek Kabelac 2012-07-10 05:25:58 EDT
I doubt this has anything related with polkit.


If I add:

ln -s /usr/share/yumex/yumex.glade  /bin/yumex.glade

I'm getting other error message - package was IMHO miscompiled into wrong location after usermove.

So while being properly installed in filesystem, it expects some files to be present in unexpected places.

i.e.:

raceback (most recent call last):
  File "/bin/yumex", line 45, in <module>
    app.run()
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 260, in run
    self.setup_gui()
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 385, in setup_gui
    accel='<Ctrl>1')
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 479, in add_page
    self.selector.add_button(key, icon=icon, tooltip=tooltip, accel=accel)
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 150, in add_button
    pb = gtk.gdk.pixbuf_new_from_file(icon)
GError: Failed to open file '/bin/../gfx/button-packages.png': No such file or directory
Comment 15 Tim Lauridsen 2012-07-10 12:32:48 EDT
(In reply to comment #14)
> I doubt this has anything related with polkit.
> 
> 
> If I add:
> 
> ln -s /usr/share/yumex/yumex.glade  /bin/yumex.glade
> 
> I'm getting other error message - package was IMHO miscompiled into wrong
> location after usermove.
> 
> So while being properly installed in filesystem, it expects some files to be
> present in unexpected places.
> 

The error reported by Steven, was another issue there relates to polkit in rawhide.
https://bugzilla.redhat.com/show_bug.cgi?id=834494

The yumex.glade not found is a bug in yumex, fixed upstrem 

test rpms is available here:
http://timlau.fedorapeople.org/files/yumex/
Comment 16 Tim Lauridsen 2012-07-17 00:46:06 EDT
*** Bug 840663 has been marked as a duplicate of this bug. ***
Comment 17 Jan Pokorný 2012-08-07 09:59:48 EDT
I hit the same problem as OP -> installed advertised test RPM -> fixed.
Comment 18 Fedora Update System 2012-08-08 04:42:03 EDT
yumex-3.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc16
Comment 19 Fedora Update System 2012-08-08 04:42:38 EDT
yumex-3.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc17
Comment 20 Fedora Update System 2012-08-09 18:50:51 EDT
Package yumex-3.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11560/yumex-3.0.6-1.fc16
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-08-24 22:57:34 EDT
yumex-3.0.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2012-08-24 23:00:17 EDT
yumex-3.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.