Bug 840663 - Yumex can no longer be run as root even with --root flag
Yumex can no longer be run as root even with --root flag
Status: CLOSED DUPLICATE of bug 827119
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 16:51 EDT by Ed Friedman
Modified: 2012-07-17 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 00:46:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2012-07-16 16:51:13 EDT
Description of problem:
yumex --root no longer works

Version-Release number of selected component (if applicable):
yumex-3.0.5-2.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1.Type:  yumex --root
2.
3.
  
Actual results:
Yumex crashes.

Expected results:
Yumex should run as root

Additional info:
The error printed out is:
Traceback (most recent call last):
  File "/bin/yumex", line 42, in <module>
    app = YumexApplication(backend)
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 203, in __init__
    Controller.__init__(self, BUILDER_FILE , 'main', domain='yumex')
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 278, in __init__
    self.ui = UI(filename, rootname, domain)
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 256, in __init__
    self.add_from_file(filename)
GError: Failed to open file '/bin/yumex.glade': No such file or directory
Comment 1 Tim Lauridsen 2012-07-17 00:46:06 EDT

*** This bug has been marked as a duplicate of bug 827119 ***

Note You need to log in before you can comment on or make changes to this bug.