Bug 827168 - [RFE] Allow a VM to run on particular selected cluster hosts
[RFE] Allow a VM to run on particular selected cluster hosts
Status: CLOSED DUPLICATE of bug 912059
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.1.0
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Doron Fediuck
Yaniv Kaul
sla
: FutureFeature
Depends On: plugable-scheduler 975630
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 15:42 EDT by Robert McSwain
Modified: 2016-02-10 15:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 12:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Robert McSwain 2012-05-31 15:42:15 EDT
1. Customer Name
A. Richard Davis - PGDS UK Ltd

2. What is the nature and description of the request?
A. RHEL HA VM cluster configuration it gives you the option of running virtual machine resources on named cluster nodes in a "one, some or all" config via the use of "failoverdomains".
This allows us to limit what cluster nodes a particular VM can run on
RHEV does not give us this option. Only a "one or all" configuration is available.

We would like to see an option to allow us to select the cluster hosts available to a particular VM, to allow us to limit the hosts on which is can run.

3. Why does the customer need this? (List the business requirements here)
A. Because it is functionality lost from RHEL VM HA clusters that we rely on to ringfence VM's to specific nodes in a cluster for application server licencing purposes.

4. How would the customer like to achieve this? (List the functional requirements here)
A. Under the "Edit Server Vitual Machine, Host tab I would line to see a selection box instead of a drop down to enable the user to select more than one cluster node.

5. For each functional requirement listed in question 4, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
A. Testing whether or not the functionality works as desired, being able to assign a VM to a particular cluster host.

6. How quickly does this need resolved? (desired target release)
A. 3.1 or 3.2

7. Would the customer be able to assist in testing this functionality if implemented?
A. Yes, we would be glad to.
Comment 1 Itamar Heim 2012-06-01 10:00:10 EDT
wouldn't negative affinity making sure the HA guests wouldn't run same host be enough?
Comment 2 Richard Davis 2012-06-15 10:51:47 EDT
Itamar - Sorry, not sure I understand the question re negative affinity.

In short, we would like the ability to enable a VM to run on a selected number of hypervisors in a cluster.   For instance, I would like my VM to run on only hypervisor nodes a,c & d  out of an available cluster consisting of hypervisor nodes a,b,c,d and e.

As it stands, we are limited to enabling our VM to run on either just one hypervisor node in the available cluster (ie. a) or all of them (ie a,b,c,d & e)

Thanks
Comment 3 Itamar Heim 2012-06-16 11:48:50 EDT
Hi Richard,

my question is if the use case behind this is to allow scheduling guests not on same set of hosts, for example, to make sure two nodes of a cluster doesn't run on the same host.

thanks,
   itamar
Comment 4 Richard Davis 2012-06-25 04:56:46 EDT
Hello Itmar

Well, thats a good point and one I'd not thought about. So yeah, thats a good reason too. Our main requirement though is to limit the hosts of a RHEV cluster that a particular VM can run on. This facility is available in RHCS by the use of the "failover domains" feature but not in RHEV. This is useful when vendors who insist on licencing their products on the volume of resourse "available" in the entire cluster. If we can prove that only a portion of a RHEV cluster is available to the guest, we can limit this cost exposure.

Thanks again
Comment 5 Itamar Heim 2012-06-27 23:23:14 EDT
ok. thanks for explaining the use case.
Comment 6 Richard Davis 2012-06-28 10:43:46 EDT
No problem. Good to see you at Summit yesterday.
Comment 7 Itamar Heim 2013-01-29 06:09:32 EST
this may end up as pinning to a tag (as a tag can be set to hosts to group them).
implementation is pending on scheduling code refactoring to make it a pluggable/extendibly interface.

Note You need to log in before you can comment on or make changes to this bug.