Bug 827308 - im-switch doesn't support gtk+ 2?
im-switch doesn't support gtk+ 2?
Status: CLOSED DUPLICATE of bug 828764
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 01:37 EDT by Mike Manilone
Modified: 2012-06-07 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 22:28:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Manilone 2012-06-01 01:37:21 EDT
Description of problem:
Use "Input Method Switcher" or "im-switch" to switch input method to iBus.
Then run 

Version-Release number of selected component (if applicable):
imsettings-1.2.9-1.fc17.x86_64

How reproducible:
Use "Input Method Switcher" or "im-switch" to switch input method to iBus. Run a GTK+2 program and try to input some characters with the input method.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Just typed some ASCII characters.

Expected results:
Input non-ASCII characters with the input method.

Additional info:
Run
export GTK_IM_MODULE=ibus
on the terminal fixed this.

Fcitx doesn't have this bug.
Comment 1 Mike Manilone 2012-06-01 01:39:47 EDT
Description of problem:
Use "Input Method Switcher" or "im-switch" to switch input method to iBus.
But can't input any non-ASCII characters in all the GTK+2 programs.
Comment 2 Akira TAGOH 2012-06-01 06:42:51 EDT
Do you have ibus-gtk2 installed?
Comment 3 Mike Manilone 2012-06-01 08:54:52 EDT
% rpm -q ibus-gtk2
ibus-gtk2-1.4.99.20120428-1.fc17.x86_64

Yes, it has been installed.
Comment 4 Mike Manilone 2012-06-03 00:34:21 EDT
I've updated to the latest ibus version and it works again.
Comment 5 Akira TAGOH 2012-06-03 21:23:12 EDT
I'm not quite sure why it did fix this issue though, you better check $HOME/.imsettings.log next time.
Comment 6 Mike Manilone 2012-06-07 09:17:31 EDT
Well, Fcitx also has this problem and it worked before.
And I found this line:
GTK_IM_MODULE: 

Is it the reason to the problem?
Comment 7 Akira TAGOH 2012-06-07 22:28:48 EDT

*** This bug has been marked as a duplicate of bug 828764 ***

Note You need to log in before you can comment on or make changes to this bug.