Bug 828764 - Request to backport the fix of better immodule fallback
Request to backport the fix of better immodule fallback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 827308 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 06:31 EDT by Akira TAGOH
Modified: 2012-06-10 19:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 19:55:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
revised patch for gtk2 (3.71 KB, patch)
2012-06-05 06:41 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2012-06-05 06:31:17 EDT
Description of problem:
After the upstream fix of https://bugzilla.gnome.org/show_bug.cgi?id=603559, setting multiple immodules for fallback works on gtk3 applications. however it breaks gtk2 applications because it doesn't parse :-separated list and tries to find immodules out as is. there are no way to avoid it since they are sharing the same XSETTINGS key. so backporting the fix is only way to go IMHO.

Version-Release number of selected component (if applicable):
gtk2-2.24.10-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.enable org.gnome.desktop.interface.show-input-method-menu to see what's going on.
2.run any gtk2 applications
3.imsettings-switch -n ibus
4.imsettings-switch -n none
  
Actual results:
3 or 4 may not take effects when looking at the input method menu.

Expected results:
3 and 4 should take effects immediately.

Additional info:
Comment 1 Akira TAGOH 2012-06-05 06:41:46 EDT
Created attachment 589482 [details]
revised patch for gtk2

Revised upstream patch of:

From 4d7e47ddd0590a6cad1bdf5d785203e8aa9f259e Mon Sep 17 00:00:00 2001
From: Akira TAGOH <akira@tagoh.org>
Date: Sat, 5 Nov 2011 01:47:46 -0400
Subject: [PATCH] Allow fallback for input method modules

Accept a :-separated list of module names in GTK_IM_MODULE and
the corresponding setting, to deal a bit better with broken
situations.
Comment 2 Matthias Clasen 2012-06-05 17:07:55 EDT
Thanks, Akira.

I've pushed this patch upstream in the gtk-2-24 branch now. I'll get to doing a 2.24.x release hopefully in the next few weeks, and we'll get this fix into F17 and F18 then. Or, if you want this resolved earlier, feel free to put the patch into our Fedora packages and push an update.
Comment 3 Akira TAGOH 2012-06-07 22:28:48 EDT
*** Bug 827308 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2012-06-07 22:32:34 EDT
Great. thanks.

Hmm, I should try to apply the patch for Fedora since someone else also is aware of this issue.
Comment 5 Fedora Update System 2012-06-07 23:47:52 EDT
gtk2-2.24.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gtk2-2.24.10-2.fc17
Comment 6 Fedora Update System 2012-06-08 20:00:34 EDT
Package gtk2-2.24.10-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk2-2.24.10-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9110/gtk2-2.24.10-2.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-10 19:55:44 EDT
gtk2-2.24.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.