Bug 827343 - HSQLDB should depend on java >= 1:1.6.0
Summary: HSQLDB should depend on java >= 1:1.6.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hsqldb
Version: 6.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Mikolaj Izdebski
QA Contact: David Kutálek
URL:
Whiteboard:
: 845539 (view as bug list)
Depends On:
Blocks: 760559 840699 844877
TreeView+ depends on / blocked
 
Reported: 2012-06-01 07:56 UTC by Alexander Todorov
Modified: 2013-02-21 08:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 844877 (view as bug list)
Environment:
Last Closed: 2013-02-21 08:43:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 845539 None None None Never
Red Hat Product Errata RHBA-2013:0334 normal SHIPPED_LIVE hsqldb bug fix update 2013-02-20 20:54:16 UTC

Internal Links: 845539

Description Alexander Todorov 2012-06-01 07:56:03 UTC
Description of problem:

Performed everything package set install to test for clean install.log

Installing hsqldb-1.8.0.10-9.el6.noarch
ln: target `hsqldb.jar' is not a directoryln: target `servlet.jar' is not a directorywarning: %post(hsqldb-1:1.8.0.10-9.el6.noarch) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):
hsqldb-1:1.8.0.10-9

How reproducible:


Steps to Reproduce:
1. Install with 
*
-@conflicts-Server
2.
3.
  
Actual results:
%post script error

Expected results:
No errors, clean install.log

Additional info:

Comment 3 Stanislav Ochotnicky 2012-06-01 15:16:25 UTC
I'll assume it was Deepak work on bug 816735 that caused this. Reassigning

Comment 4 Deepak Bhole 2012-06-01 15:37:59 UTC
I cannot see how my changes could have caused this error as I changed nothing in the code that related to what %post does. 

Also, I am unable to reproduce this in a local VM:

[root@dhcp-10-15-16-104 tmp]# rpm -q hsqldb
hsqldb-1.8.0.10-8.el6.x86_64
[root@dhcp-10-15-16-104 tmp]# rpm -Uvh hsqldb-1.8.0.10-9.el6.noarch.rpm 
Preparing...                ########################################### [100%]
   1:hsqldb                 ########################################### [100%]
[root@dhcp-10-15-16-104 tmp]# rpm -e hsqldb
[root@dhcp-10-15-16-104 tmp]# rpm -q hsqldb
package hsqldb is not installed
[root@dhcp-10-15-16-104 tmp]# rpm -ivh hsqldb-1.8.0.10-9.el6.noarch.rpm 
Preparing...                ########################################### [100%]
   1:hsqldb                 ########################################### [100%]
[root@dhcp-10-15-16-104 tmp]#

Comment 6 Deepak Bhole 2012-06-01 15:52:44 UTC
It would have been interesting to see what the state of the system was when the error happened. 

The error message in the original report is shown when ln is given 2+ args and the last is not a directory. It is from these line in %post:

    ln -s $(build-classpath hsqldb) hsqldb.jar
    ln -s $(build-classpath apache-tomcat-apis/tomcat-servlet2.5-api) servlet.jar


That means that both, $(build-classpath hsqldb) and $(build-classpath apache-tomcat-apis/tomcat-servlet2.5-api) returned more than one value.. it is wierd that build-classpath saw two or more jars for each of them.

So is it okay to close this bug as WORKSFORME?

Comment 21 Mikolaj Izdebski 2012-09-19 08:39:01 UTC
*** Bug 845539 has been marked as a duplicate of this bug. ***

Comment 25 errata-xmlrpc 2013-02-21 08:43:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0334.html


Note You need to log in before you can comment on or make changes to this bug.