Bug 845539 - hsqldb installation errors
hsqldb installation errors
Status: CLOSED DUPLICATE of bug 827343
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hsqldb (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mikolaj Izdebski
BaseOS QE - Apps
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 07:38 EDT by Oleg L. Sadov
Modified: 2012-09-19 04:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 04:39:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add missing Requires: java (1.16 KB, patch)
2012-08-03 08:38 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Oleg L. Sadov 2012-08-03 07:38:04 EDT
Description of problem:
Installation of hsqldb package on system without installed Java environment finished with error messages.

Version-Release number of selected component (if applicable):
hsqldb-1.8.0.10-9.el6.noarch

How reproducible:
Try to install hsqldb package on system without installed Java environment.

Steps to Reproduce:
1. Install system without Java environment.
2. Install hsqldb-1.8.0.10-9.el6.noarch package
3.
  
Actual results:

Error messages:
ln: target `hsqldb.jar' is not a directory
ln: target `servlet.jar' is not a directory
warning: %post(hsqldb-1:1.8.0.10-9.el6.noarch) scriptlet failed, exit

Symbolic links for hsqldb.jar and servlet.jar in /var/lib/hsqldb/lib not formed.

Expected results:
Installtion without error messages. Creating symbolic links for hsqldb.jar and servlet.jar in /var/lib/hsqldb/lib.

Additional info:
Error in postinstall scriptlet is generated by build-classpath shell-script which can't find Java environment:

# build-classpath hsqldb
Can't find java virtual machine, aborting.
# build-classpath apache-tomcat-apis/tomcat-servlet2.5-api
Can't find java virtual machine, aborting.

After installing of java-1.6.0-openjdk package installation of hsqldb package finished successfully.

Possible solution -- add requirements for java to hsqldb or jpackage-utils packages.
Comment 2 Mikolaj Izdebski 2012-08-03 08:38:33 EDT
Created attachment 602127 [details]
Add missing Requires: java

Reproduced on Red Hat Enterprise Linux Server release 6.3 (Santiago).
Patch is attached.

Workaround: install java before installing hsqldb.
Comment 5 Mikolaj Izdebski 2012-09-19 04:39:01 EDT

*** This bug has been marked as a duplicate of bug 827343 ***

Note You need to log in before you can comment on or make changes to this bug.