Bug 827432 - Fedora 17 won't un-suspend on Macbook Unibody
Fedora 17 won't un-suspend on Macbook Unibody
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 795511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 09:18 EDT by yerazunis
Modified: 2013-03-28 09:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-28 09:55:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yerazunis 2012-06-01 09:18:53 EDT
Description of problem:

 Fedora 17 won't un-suspend on Macbook Unibody

Version-Release number of selected component (if applicable):

 Fedora 17

How reproducible:

 Every Time

Steps to Reproduce:

1.  Obtain Fedora 17 Live CD
2.  Boot it.  Observe that it's a nice system.
3.  Close lid
  
Actual results:

 - Display remains off.  No backlight, no graphics.

Expected results:

 - System should resume.  Worked in Fedora 14


Additional info:

  Bug may be common with bug 795511 (same bug as in Fedora 16)
Comment 1 yerazunis 2012-06-01 15:45:46 EDT
Additional info:

Ubuntu 12.04 LTS liveCD - does not unsuspend correctly.

Fedora 17 LXDE liveCD spin - Functions correctly!
Comment 2 yerazunis 2012-06-02 01:43:23 EDT
Cancel the added comment that LXDE liveCD works.  

In fact, it never suspends at all (which may be an entirely different issue),
but it's not a fix.  The backlight remains on and the CPU keeps running, not
hibernating, and power use remains high.

I regret the false information.
Comment 3 Frederic Riss 2012-06-18 02:45:24 EDT
I confirm that I see the same behavior, with the additional symptom that after a few seconds with a black screen, the system reboots.
Comment 4 Frederic Riss 2012-07-01 04:12:10 EDT
Just to point out that I upgraded the kernel to 3.4.4-3.fc17.x86_64 and it didn't change anything. The screen still doesn't come back after suspend. 

Any additional data needed ?
Comment 5 Frederic Riss 2012-07-04 14:42:27 EDT
This must be related to nouveau. Installing the nvidia binary blob from rpmfusion gives me working suspend. Shall we reassign the bug?
Comment 6 yerazunis 2012-07-04 19:39:32 EDT
We've had conflicting reports as to whether the bug is in nouveau itself or in
the kernel (I originally reported it as a nouveau bug back at F15, and it's 
bounced back and forth for a while now.)  

I'd really rather have it fixed than just reassigning it one more time; that's
boring and doesn't actually fix the bug.

   - Bill
Comment 7 Josh Boyer 2012-07-10 12:40:40 EDT
Please try the 3.4.4-5 kernel.  It has a nouveau suspend fix.

If that still fails, please try some of the tips located here to narrow down which driver may be causing the issue:

http://fedoraproject.org/wiki/Common_kernel_problems#Suspend.2FResume_failure
Comment 8 Roman Melihhov 2012-07-13 10:32:58 EDT
AMD x86_64 fedora17 same thing, after 2 or 3 most recent kernel updates. All worked with initial kernel installation  does not with the latest.
Comment 9 Roman Melihhov 2012-07-13 10:35:04 EDT
Kernel Linux 3.4.4-5.fc17.x86_64

GNOME 3.4.2

CPU: AMD Phenom(tm) II X4 965 Processor × 4

system does not suspend, fan is running but screen goes black (and remains black).
Comment 10 Josh Boyer 2012-09-04 15:22:41 EDT
*** Bug 795511 has been marked as a duplicate of this bug. ***
Comment 11 Josh Boyer 2013-03-14 14:25:30 EDT
Is this still happening with 3.8.2 in updates-testing?
Comment 12 Josh Boyer 2013-03-28 09:55:21 EDT
This bug is being closed with INSUFFICIENT_DATA as there has not been a
response in 2 weeks.  If you are still experiencing this issue,
please reopen and attach the relevant data from the latest kernel you are
running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.