Bug 82746 - Fail to use smbmount with Phoebe 8.1b2
Summary: Fail to use smbmount with Phoebe 8.1b2
Status: CLOSED DUPLICATE of bug 82820
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-25 18:12 UTC by Eric Hartmann
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Hartmann 2003-01-25 18:12:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Hi,

I've just tested Phoebe b2 and found an annoying problem with this configuration :
* Dell Optiplex gx260
* Network card Intel Gigabyte (e1000.o) 


I try to mount 10 shares from different server (Windows and Samba 2.0). So I
create my directories and put everything in /etc/fstab : 

//server1/public  /mnt/server1/public   smbfs  credentials=/etc/samba/auth 0 0
....
....
//server10/public  /mnt/server10/public   smbfs  credentials=/etc/samba/auth 0 0

The I try to mount everything with "mount -a". But mount freeze after the
third/fourth server (changing the order does not help). 

I use debug=9 option to see where is the problem but everything was fine, I
think it's the process mount.smbfs that cannot "detach" itself  from his parent
(that is what i see when I do a ps -ef)

After some reading, I try to use LD_ASSUME_KERNEL=2.2.5, but this doesnot help
with mount -a, however by using this, I'm able to mount everything by hand with
smbmount (so not using /etc/fstab).



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Create ten different shares and add them to fstab
2. Try to mount them with 'mount -a'
3. The process hang 


    

Actual Results:  A ps -ef --forest show this :
   mount -a
     \-/sbin/mount.smbfs //server1/public -o rw ....
        \-/sbin/mount.smbfs  //server1/public -o rw ....

With debug=9, everything seems fine, the last lines are :
smb_vwv[0]=255 (0xFF)
smb_vwv[1]=49 (0x31)
smb_bcc=8
3904: tconx ok

Expected Results:  The process should not hang.

Additional info:

I'm not a linux guru so I don't know how to go further.

Comment 1 Michael Wardle 2003-03-06 03:37:16 UTC
This appears to be the earliest reported bug on the same lines as bug 82820,  
but that bug has all the discussion, and the appropriate priority and severity.  
  
Suggest this be resolved as a duplicate of bug 82820. 
 
Please also note that the product and version numbers used in this bug are 
incorrect (should be Red Hat Public Beta and Phoebe as with bug 82820). 
 

Comment 2 David Lawrence 2003-03-06 04:20:56 UTC
Resolving duplicate per user request.

*** This bug has been marked as a duplicate of 82820 ***

Comment 3 Jan Houtsma 2003-04-20 15:24:39 UTC
Let's see if i can add comments this time. I created the bugreport below 
because i couldn't add comments here before. This is just a check if i 
can now. Please also see http://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=89197 for more information and traces about this problem.


Comment 4 Jan Houtsma 2003-04-20 15:26:17 UTC
C&P error. The link should be:
http://bugzilla.redhat.com/bugzilla/show_bug.cgiid=89197


Comment 5 Jan Houtsma 2003-04-20 15:28:56 UTC
Grr. It's not a C&P bug but the form behaves wierd when the URL wraps off at 
the right site of the Additional Comments form. So now the link should be fine 
(hopefully):

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=89197

Comment 6 Red Hat Bugzilla 2006-02-21 18:51:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.