Bug 82820 - Mounting of a smbfs will sometimes hang the mount command.
Mounting of a smbfs will sometimes hang the mount command.
Status: CLOSED DUPLICATE of bug 90036
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
: 82746 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-27 04:58 EST by Ivo Sarak
Modified: 2006-02-21 13:51 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2003-01-27 04:58:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
After upgrade from RedHat Linux 8.0 to RedHat Linux 8.0.93, when to issue a 
"mount -t smbfs -o username=guest,password=foobar //machine/share
/mnt/samba/machine/share", then sometimes it will never leave the mount command.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Upgrade to Phoebe (8.0.93);
2. Issue series of "mount -t smbfs ..." commands to various smb shares;
    

Actual Results:  It will hang at random mount. I have 10 such kind of mounts and
maximum count of successful mounts has been 8.

Expected Results:  If something is wrong then it should state it and carry on.

Additional info:

I see no error messages.

It is already bad that I can not browse the smb shares with konqueror
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75765 , but now I can not
even mount these. What is going on with the smb & kde & redhat?

Luckily it is possible to outcome this issue with a "&": "mount -t smbfs -o
username=guest,password=foobar //machine/share /mnt/samba/machine/share &"
Comment 1 Elliot Lee 2003-02-19 17:49:06 EST
Can't reproduce here. Did 20 mounts of a samba server, no problems at all.
Comment 2 keith adamson 2003-02-21 12:31:50 EST
I have the same problem on phoebe 3 for mounting a win2000 server's services. 
Works ok on redhat 8.0!

Completes first mount of a //server/service1. Hangs on second mount of
//server/service2.  Note that in my case the two services are on the same server
and I need to use the "workgroup" option to gain authority.  There are other
services on the same server that I do not have authority for.

/etc/fstab:

//server/service1 /home/me/server/service1 smbfs
uid=me,gid=me,credentials=/home/me/mywincreds,workgroup=mywingrp 0 0

//server/service2 /home/me/server/service2 smbfs
uid=me,gid=me,credentials=/home/me/mywincreds,workgroup=mywingrp 0 0

/home/me/mywincreds ... permissions 600:

username = mywinuid
password = mywinpassword

then as root:

"mount /home/me/server/service1" completes ok.

"mount /home/me/server/service2" hangs every time indefinitely but the service
seems to be mounted ok.

Comment 3 Ivo Sarak 2003-02-21 15:38:04 EST
Is there any information I can give to detect the source of this problem?

As I am not alone with this problem, I reopen this bug (I suspect a closed bug
will never gain attention).
Comment 4 Elliot Lee 2003-02-24 07:51:51 EST
Sure - information on how I can reproduce the problem on my system :) The main problem 
is that very often, environmental factors such as system or network configuration make 
that impossible. e.g. someone commented that they saw the problem when mounting from 
a win2k server, which I am not going to use.

Ideas always welcome...
Comment 5 keith adamson 2003-02-24 23:13:49 EST
Elliot, 

Have you tried with a win2k server that has services privileged by user and
workgroup?

Like I said, the very same configuration I defined above works with 8.0 but not
with phoebe 3.  Mount always hangs on the second mount.  I'll try to get some
time tomorrow to play with this at work some more.  
Comment 6 Elliot Lee 2003-02-24 23:39:21 EST
I don't have a win2k box handy, and priorities don't permit setting one up right now. 
Patches & more info welcome in the meantime.
Comment 7 Michael Wardle 2003-03-04 23:20:03 EST
I'm also experiencing such problems in Red Hat 8.0.94 on i386,
and also had this working properly on Red Hat 8.0.

I am attempting to mount a number of Windows NT and Windows 2000
shares on my Red Hat box using autofs.  I am able to connect to
these shares using smbclient, but performing an operation which
would cause automount to attempt to mount the share under the
/net hierarchy (such as "ls /net/machine/share") on my box often
hangs on the first attempt, then often succeeds on the second
attempt.

Increasing the samba debugging level to 5 still shows no clues
in the samba log files.
Comment 8 Michael Wardle 2003-03-05 22:28:05 EST
This is really weird.  The last time I saw this happen, I had a process list something like: 
/bin/mount -t smbfs -s -o username=xxx,password=xxx //server/share /net/server/share 
/sbin/mount.smbfs //server/share /net/server/share -o rw username xxx password xxx 
/sbin/mount.smbfs //server/share /net/server/share -o rw username xxx password xxx 
 
The first mount.smbfs was a child of mount, and the second mount.smbfs was a child 
of the first mount.smbfs. 
 
Comment 9 David Lawrence 2003-03-05 23:20:59 EST
*** Bug 82746 has been marked as a duplicate of this bug. ***
Comment 10 Ivo Sarak 2003-04-22 04:47:18 EDT
For the record - shares I am trying to smbmount are running RedHat Linux.
Some other reports with the same issue:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=89197
Comment 11 Ken Pratt 2003-04-23 09:51:01 EDT
I am using a fully updated version (as of 4/23/03) of RedHat 9 and am
experiencing the vary same problems.  I discovered the problem while trying to
set up autofs to mount three win2k shares from the same server automatically. 
Currently, I have to mount the shares manually and use a CTRL-C to kill the
mount command when it hangs.  It acts as if the underlying mount process
sometimes fails to inform the parent process of success or failure.  Is it an
IPC problem?
Comment 12 Jan Houtsma 2003-04-23 15:31:27 EDT
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=89197 also contains 
additional traces for this same problem which confirms Ken Pratt's comment #11.
The underlying smbmount process doesn't inform the parent smbmount process 
with a result (for whatever reason) and both processes hang because of that.
It -is- a kernel problem. People confirmed that another rebuilt kernel fixed 
the problem (either because of different kernel code or because of other 
switches that were chosen for the build).
Comment 13 Justin Georgeson 2003-04-28 11:20:21 EDT
i have it too, RH 9, fully up2date, Win 2K Pro SP2
Comment 14 Jay Fenlason 2003-05-01 11:24:52 EDT
We've traced this down to a bug in glibc.  At the request of one of the glibc
maintainers, I've opened a new bug against glibc for it.  I'm going to mark all
these smbmount bugs as duplicates of the new bug.

*** This bug has been marked as a duplicate of 90036 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:51:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.