Bug 827546 - Selecting changeset from 'changeset history' tab raising "undefined method `find_repos' for #"
Selecting changeset from 'changeset history' tab raising "undefined method `f...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
: Triaged, ZStream
Depends On: 807288
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 14:10 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When users select a changeset from 'changeset history' tab, it raises an "undefined method 'find_repos' for #" error message. This update allows users to select and promote changeset from 'changeset history' tab without the error message.
Story Points: ---
Clone Of: 807288
Environment:
Last Closed: 2012-07-10 03:24:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Promoting blacklisted packages (38.84 KB, image/png)
2012-06-07 01:46 EDT, Sachin Ghai
no flags Details
no error raised while clicking the changeset that we created for promotion of blacklisted packages (48.62 KB, image/png)
2012-06-07 01:48 EDT, Sachin Ghai
no flags Details

  None (edit)
Comment 4 Sachin Ghai 2012-06-07 01:45:47 EDT
Verified with latest puddle:

[root@dhcp201-221 ~]# rpm -qa | grep katello-0
katello-0.1.313-1.el6_3.noarch


I tried to promote the balcklisted packages and checked the changeset under changeset history tab. No error raised on UI.

for ex: Here I created a re-promote changeset and promoted 2 blacklisted packages as per attachment. After promotion, I checked the 're-promote' chnageset under 'changeset history' tab and no 'undefined method' error raised.
Comment 5 Sachin Ghai 2012-06-07 01:46:59 EDT
Created attachment 590078 [details]
Promoting blacklisted packages
Comment 6 Sachin Ghai 2012-06-07 01:48:11 EDT
Created attachment 590079 [details]
no error raised while clicking the changeset that we created for promotion of blacklisted packages
Comment 7 sachua 2012-06-12 22:09:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When users select a changeset from 'changeset history' tab, it raises an "undefined method 'find_repos' for #" error message. This update allows users to select and promote changeset from 'changeset history' tab without the error message.
Comment 9 errata-xmlrpc 2012-07-10 03:24:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html
Comment 10 Mike McCune 2013-08-16 13:56:01 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.