Bug 807288 - Selecting changeset from 'changeset history' tab raising "undefined method `find_repos' for #"
Summary: Selecting changeset from 'changeset history' tab raising "undefined method `f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Petr Chalupa
QA Contact: Og Maciel
URL:
Whiteboard:
: 820882 (view as bug list)
Depends On:
Blocks: 827546
TreeView+ depends on / blocked
 
Reported: 2012-03-27 12:50 UTC by Sachin Ghai
Modified: 2019-09-26 15:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the "Changeset History" tab, selecting changesets with blacklisted packages from a previously promoted changeset raises an error: "undefined method 'find repos' for #." This fix corrects rendering logic. Changesets with previously blacklisted packages now display without causing an error.
Clone Of:
: 827546 (view as bug list)
Environment:
Last Closed: 2012-12-04 19:44:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
selecting changeset from changeset history tab raised undefined error (53.88 KB, image/png)
2012-03-27 12:51 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2012:1543 0 normal SHIPPED_LIVE Important: CloudForms System Engine 1.1 update 2012-12-05 00:39:57 UTC

Description Sachin Ghai 2012-03-27 12:50:38 UTC
Description of problem:
I applied package filters on a custom product and later tried to promote the product. Product was promoted successfully with applied filters.

Later I tried to re-promote the blacklisted packages to same env. Promotion was successful but none of the blacklisted packages were promoted to next env. And I think it is expected. 

However when I selected the changeset created for blacklist package promotion from the changeset history tab, UI raised following error:

undefined method `find_repos' for #

Version-Release number of selected component (if applicable):
pulp-1.0.0-6.el6.noarch
katello-0.1.306-1.el6.noarch
katello-glue-candlepin-0.1.306-1.el6.noarch
candlepin-0.5.26-1.el6.noarch
katello-cli-0.1.107-1.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Create a product/repo and sync it ( Let's say pulp repo)
2. created package filter and filter out gofer and grinder packages and select the pulp product.
3. Create a changeset1 and promote the pulp product.
4. All packages should be promoted except gofer and grinder
5. Now create another changeset2 and add blacklisted packages ( gofer, grinder) to new changeset2 and promote them. 
Note: Promotion should be successful but in actual none of the blacklisted package should be promoted
6. Go to changeset history tab and select changeset2
 
Actual results:

undefined method `find_repos' for #


Expected results:
There shouldn't be any error on UI after selecting the changeset from changeset history tab

Additional info:

Comment 1 Sachin Ghai 2012-03-27 12:51:50 UTC
Created attachment 573054 [details]
selecting changeset from changeset history tab raised undefined error

Comment 3 Sachin Ghai 2012-04-18 17:23:24 UTC
Yes, its still reproducible in latest katello build:

katello-0.1.310-1.el6_2.noarch

This defect is not a blocker as its not blocking any function/feature, however if its a easy fix then I think its good to include in V1.0. This issue appears with 'Changeset history' tab. And its a separate tab in UI. So customer will surely check/try this tab once. 

Again good to include if its a easy fix.

Comment 5 Mike McCune 2012-05-16 15:36:43 UTC
Moving to 1.0.1 since it blocks the usage of the Changeset History page

Comment 6 Petr Chalupa 2012-05-30 13:38:49 UTC
*** Bug 820882 has been marked as a duplicate of this bug. ***

Comment 7 Petr Chalupa 2012-05-31 09:52:22 UTC
fixed in 90800a766f6b69e8ec506c975a6ca6bcb12ad9d6

Comment 10 Og Maciel 2012-09-14 21:59:23 UTC
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-7.el6cf.noarch
* katello-all-1.1.12-7.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-4.el6cf.noarch
* katello-cli-common-1.1.8-4.el6cf.noarch
* katello-common-1.1.12-7.el6cf.noarch
* katello-configure-1.1.9-3.el6cf.noarch
* katello-glue-candlepin-1.1.12-7.el6cf.noarch
* katello-glue-pulp-1.1.12-7.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch

Comment 12 errata-xmlrpc 2012-12-04 19:44:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2012-1543.html


Note You need to log in before you can comment on or make changes to this bug.