Bug 827665 - can't boot newly installed F17
can't boot newly installed F17
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 827726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 02:51 EDT by Arnold Wang
Modified: 2013-08-01 04:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 04:54:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Logs. (95.38 KB, application/x-gzip)
2012-06-02 13:51 EDT, Arnold Wang
no flags Details
anaconda.yum.log (180.11 KB, text/plain)
2012-06-04 15:30 EDT, Arnold Wang
no flags Details
anaconda.syslog (148.08 KB, text/plain)
2012-06-04 15:31 EDT, Arnold Wang
no flags Details
anaconda.storage.log (163.55 KB, text/plain)
2012-06-04 15:32 EDT, Arnold Wang
no flags Details
anaconda.program.log (149.09 KB, text/plain)
2012-06-04 15:32 EDT, Arnold Wang
no flags Details
anaconda.log (21.58 KB, text/plain)
2012-06-04 15:33 EDT, Arnold Wang
no flags Details
grub.conf (816 bytes, text/plain)
2012-06-04 15:59 EDT, Arnold Wang
no flags Details

  None (edit)
Description Arnold Wang 2012-06-02 02:51:56 EDT
Description of problem:
I just installed F17 on my Dell Latitude E6410 laptop in UEFI mode. The installation went OK, it created a 200 MB EFI system partition mounted as /boot/efi. When I rebooted after the installation completed, it went into GRUB prompt instead of booting F17. 

Version-Release number of selected component (if applicable):
F17
GRUB 0.97-93.fc17


How reproducible:
Install F17 in EFI mode.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The system won't boot.

Expected results:
The system boot into F17.

Additional info:
Comment 1 Vladimir Serbinenko 2012-06-02 03:01:16 EDT
The component you specified is wrong since you use GRUB 0.97 and not GRUB2
Comment 2 Mads Kiilerich 2012-06-02 08:55:48 EDT
Fixed component.
Comment 3 Arnold Wang 2012-06-02 12:51:39 EDT
Thanks for the quick response. 
I went through the installation process again and there is no option for me to choose GRUB or GRUB2. I tried to customize the packages and all I can select are those optional packages, I can't modify those "core" packages.
I'm not sure what I can do at this point other than go back to the BIOS mode. Any suggestion?
Thanks again for all the helps.
Comment 4 Mads Kiilerich 2012-06-02 12:57:20 EDT
anaconda.log and program.log might tell what went wrong - you could try to attach them here.
Comment 5 Arnold Wang 2012-06-02 13:51:18 EDT
Created attachment 588684 [details]
Anaconda Logs.
Comment 6 Brian Lane 2012-06-04 11:46:10 EDT
Please attach logs as individual text/plain files (everything in /tmp/*log), this make is easier to view them and search them.
Comment 7 Arnold Wang 2012-06-04 15:30:25 EDT
Created attachment 589260 [details]
anaconda.yum.log
Comment 8 Arnold Wang 2012-06-04 15:31:36 EDT
Created attachment 589261 [details]
anaconda.syslog
Comment 9 Arnold Wang 2012-06-04 15:32:07 EDT
Created attachment 589262 [details]
anaconda.storage.log
Comment 10 Arnold Wang 2012-06-04 15:32:44 EDT
Created attachment 589263 [details]
anaconda.program.log
Comment 11 Arnold Wang 2012-06-04 15:33:57 EDT
Created attachment 589264 [details]
anaconda.log
Comment 12 Brian Lane 2012-06-04 15:57:26 EDT
Could you attach grub.conf as well?
Comment 13 Arnold Wang 2012-06-04 15:59:56 EDT
Created attachment 589268 [details]
grub.conf
Comment 14 Mads Kiilerich 2012-06-04 20:52:51 EDT
without knowing grub legacy and what to look for I notice the following which seems suspicious to me:

10:07:44,711 INFO storage: bootloader stage1 target device is sda1
10:07:44,714 INFO storage: bootloader stage2 target device is sda2
10:07:45,876 INFO storage: bootloader.py: used boot args: rd.md=0 rd.dm=0 rd.lvm.lv=vg_arnoldw/lv_swap  KEYTABLE=us rd.lvm.lv=vg_arnoldw/lv_root rd.luks=0 ro root=/dev/mapper/vg_arnoldw-lv_root SYSFONT=True LANG=en_US.UTF-8 rhgb quiet 
10:07:45,876 ERR storage: failed to create grub menu.lst symlink: [Errno 1] Operation not permitted
10:07:45,884 WARN storage: Storage.writeKS not completely implemented

and

device (hd0,1) HD(1,800,64000,6f07d705-ee3a-4e1e-8280-5dba3e44681c)
Comment 15 James Harrion 2012-07-15 18:33:37 EDT
I have a Dell Lattitude E6410. 8Gb RAM

I've just upgraded from FEDORA 15 to Fedora 17.

I used preupgrade. The upgrade worked OK. Booting the machine after the upgrade was not successful.

I then tried a fresh install DVD and I could boot the machine after the install completed.. 
After a "yum upgrade" I could not boot the machime with the updated kernel

The two kernels are different:
3.3.4-5.fc17.x86_64  (Installed after the fresh install)
3.4.4-5.fc17.x86_64  (Installed after yum update)

So my question is: if one allows the machine to boot and the other does not.... Whats the difference between the two?

Not sure if I am using efi... Just took the defaults.
Comment 16 Mads Kiilerich 2012-07-31 15:40:58 EDT
*** Bug 827726 has been marked as a duplicate of this bug. ***
Comment 17 Mads Kiilerich 2012-07-31 15:54:34 EDT
This model seems to have some serious issues - e.g. bug 810888.
Comment 18 Fedora End Of Life 2013-07-03 22:37:42 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 19 Fedora End Of Life 2013-08-01 04:54:47 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.