Bug 827695 - [abrt] libreoffice-core-3.5.4.2-1.fc18: SwRenderData::~SwRenderData killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.4.2-1.fc18: SwRenderData::~SwRenderData killed by...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:4222c629653a954ec9c4042f719...
:
: 848295 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 07:25 EDT by Nicolas Mailhot
Modified: 2012-10-11 10:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 10:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (22.73 KB, text/plain)
2012-06-02 07:26 EDT, Nicolas Mailhot
no flags Details
File: maps (130.06 KB, text/plain)
2012-06-02 07:26 EDT, Nicolas Mailhot
no flags Details
File: backtrace (46.00 KB, text/plain)
2012-06-02 07:26 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2012-06-02 07:25:56 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/nim/Documents/immobilier-val-de-seine/travaux/lettre%20SAS%20Hubert.odt --splash-pipe=6
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.0-2.fc18.x86_64
pid:            3226
pwd:            /home/nim
time:           sam. 02 juin 2012 11:16:48 CEST
uid:            500
username:       nim
xsession_errors: 

backtrace:      Text file, 47100 bytes
dso_list:       Text file, 23279 bytes
maps:           Text file, 133178 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/nim/2

core_backtrace:
:- 0x0 - - -
:b92940d5aa19251f1fe552752bbbbce6271b6e2b 0x9b2c11 - libswlo.so -
:b92940d5aa19251f1fe552752bbbbce6271b6e2b 0x72b07a - libswlo.so -
:b92940d5aa19251f1fe552752bbbbce6271b6e2b 0x9b288a SwXTextDocument::~SwXTextDocument() libswlo.so -
:b92940d5aa19251f1fe552752bbbbce6271b6e2b 0x9b2ba9 SwXTextDocument::~SwXTextDocument() libswlo.so -
:b54f7d3300b8d746d0016a764bcd4da36f38d7b6 0x324c62 SfxBaseController::dispose() libsfxlo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x1492f4 - libfwklo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x148ddd - libfwklo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x13afa1 - libfwklo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x13c977 - libfwklo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x95b12 - libfwklo.so -
:07460d986046cb578b9e232c0cdb8e92e73e51df 0x96316 - libfwklo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0x2b2fca - libvcllo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0x352d12 - libvcllo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0x35c3c1 SalGenericDisplay::DispatchInternalEvent() libvcllo.so -
:ca4f2bc68a58da6a556f6673a8098e429fce9f39 0x30fcf - libvclplug_gtklo.so -
:ca4f2bc68a58da6a556f6673a8098e429fce9f39 0x31049 - libvclplug_gtklo.so -
:c0df081b565ef88f155cf8d19ba042a20cdaba6d 0x47815 g_main_context_dispatch libglib-2.0.so.0 -
:c0df081b565ef88f155cf8d19ba042a20cdaba6d 0x47b48 - libglib-2.0.so.0 -
:c0df081b565ef88f155cf8d19ba042a20cdaba6d 0x47c04 g_main_context_iteration libglib-2.0.so.0 -
:ca4f2bc68a58da6a556f6673a8098e429fce9f39 0x30d71 - libvclplug_gtklo.so -
:ca4f2bc68a58da6a556f6673a8098e429fce9f39 0x31acd - libvclplug_gtklo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0xfbbe4 Application::Yield(bool) libvcllo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0xfbc87 Application::Execute() libvcllo.so -
:3ccd657809737fb3de7a816b9fbe6349edfa0dfb 0x1dd59 - libsofficeapp.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0x102621 - libvcllo.so -
:ec6b1d57e4672f2d081db1ef42c0402af5d52246 0x1026c5 SVMain() libvcllo.so -
:3ccd657809737fb3de7a816b9fbe6349edfa0dfb 0x41d36 soffice_main libsofficeapp.so -
:da26ae7b69671d8091902c9714ee2396f2c11d12 0x6bb - [exe] -

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=arekh.okg
:GIO_LAUNCHED_DESKTOP_FILE_PID=3212
:GPG_AGENT_INFO=/run/user/nim/keyring-SB3ufi/gpg:0:1
:SHELL=/bin/bash
:DESKTOP_STARTUP_ID=nautilus-2514-arekh.okg-libreoffice-0_TIME4125456
:HISTSIZE=1000
:XDG_SESSION_COOKIE=600ffe0ff55806cd11d94c624a4f786e-1338623529.541587-2087528119
:CVSROOT=:ext:nim@cvs.fedoraproject.org:/cvs/extras
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/nim/keyring-SB3ufi
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=nim
:SSH_AUTH_SOCK=/run/user/nim/keyring-SB3ufi/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1469,unix/unix:/tmp/.ICE-unix/1469
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/nim
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/nim/bin
:DESKTOP_SESSION=gnome
:PWD=/home/nim
:GNOME_KEYRING_PID=1455
:LANG=fr_FR.UTF-8
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/nim
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=nim
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-lEHCHuDuXb,guid=63633530819ecaf351e6daac000000d0
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/nim
:DISPLAY=:0.0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-nim-rsLrUH/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31290                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31290                31290                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/nim/.xsession-errors
:2:/home/nim/.xsession-errors
:3:socket:[200175]
:4:anon_inode:[eventfd]
:5:pipe:[200142]
:6:pipe:[200142]
:7:socket:[200179]

smolt_data:
:
:
:Général
:=================================
:UUID: b78fe0ae-e51d-40f8-8e68-7f2478f9cf2a
:SE: Fedora release 18 (Rawhide)
:Niveau d'exécution par défaut: 5
:Langue: fr_FR.UTF-8
:Plateforme: x86_64
:BogoMIPS: 6332.65
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz
:Stepping du processeur: 10
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 2
:Vitesse du processeur: 2834
:Mémoire du système: 3934
:Swap du système: 4094
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: EP45-DS5 
:Type d'ordinateur: Desktop
:Noyau: 3.4.0-2.fc18.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:11808:5208:20480) pci, None, HOST/PCI, GA-EP45-DS5 Motherboard
:(32902:11809:5208:20480) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:14896:5208:20481) pci, i801_smbus, SERIAL, GA-EP45-DS5 Motherboard
:(32902:14882:5208:45061) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14870:5208:20481) pci, None, PCI/ISA, GA-EP45-DS5 Motherboard
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14901:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14900:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14905:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14902:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14906:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14908:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, pata_jmicron, STORAGE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14918:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14912:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14920:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14910:5208:41218) pci, snd_hda_intel, MULTIMEDIA, GA-EP45-DS5 Motherboard
:(4354:4:4354:16385) pci, snd_emu10k1, MULTIMEDIA_AUDIO, E-MU 1010
:(32902:14903:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4354:16385:4354:16) pci, firewire_ohci, FIREWIRE, SB Audigy FireWire Port
:(17476:22:112:32771) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 150
:(32902:14904:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4098:43672:5963:43672) pci, snd_hda_intel, MULTIMEDIA, Sapphire HD 6450 1GB DDR3
:(4098:26489:5963:57700) pci, radeon, VIDEO, Sapphire HD 6450 1GB DDR3
:(32902:14922:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup00-systeme / ext4 4096 4096 12496068 7240971 6611877 3145728 2646859 2646859
:/dev/mapper/VolGroup00-utilisateur /home ext4 4096 4096 25127330 4834240 3575950 6291456 6169978 6169978
:/dev/md0 /boot ext4 4096 4096 522607 494271 468091 131072 130806 130806
:

var_log_messages:
:Jun  2 11:16:48 arekh kernel: [ 5286.359476] soffice.bin[3226]: segfault at 32ffa70 ip 00000000032ffa70 sp 00007fff89146e88 error 15
:Jun  2 11:16:51 arekh abrt[7119]: Saved core dump of pid 3226 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-02-11:16:48-3226 (121131008 bytes)
Comment 1 Nicolas Mailhot 2012-06-02 07:26:07 EDT
Created attachment 588650 [details]
File: dso_list
Comment 2 Nicolas Mailhot 2012-06-02 07:26:10 EDT
Created attachment 588651 [details]
File: maps
Comment 3 Nicolas Mailhot 2012-06-02 07:26:12 EDT
Created attachment 588652 [details]
File: backtrace
Comment 4 Caolan McNamara 2012-06-05 06:58:29 EDT
Was this after printing a document, or print preview and/or export to pdf. Something like that ?

Does it always happen or need a specific document to trigger ? Not the first time that blasted SwRenderData has appeared in a backtrace
Comment 5 Nicolas Mailhot 2012-06-05 07:15:00 EDT
I noticed the alert after closing writer
It had been used in a (failed) attempt to print a few pages before
Comment 6 Michael Stahl 2012-09-26 06:51:43 EDT
*** Bug 848295 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl 2012-09-26 07:01:27 EDT
problem is trivial to reproduce after commenting out the special
handling of bLastPage in SwXTextDocument::render();
appartently it is possible in practice that the last-page
call that is necessary to cleanup stuff in Writers awful
XRenderable implemetation does not happen for whatever reason.

when closing the document SwView::~SwView deletes the
ViewShell (SwWrtShell really) and then later that is still
accessed by code that should have been cleaned up with bLastPage.

added a horrible kludge so we don't crash any more on upstream master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d53e12c7a9c2d0a3b487303673c1fafd09f6593c
Comment 8 Michael Stahl 2012-09-28 13:23:39 EDT
fix for this should be in next F17 upload 3.5.6.2-7

fix is in upstream libreoffice-3-6 for 3.6.3 as well:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d53e12c7a9c2d0a3b487303673c1fafd09f6593c
Comment 9 Fedora Update System 2012-10-05 01:30:09 EDT
libreoffice-3.5.7.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-2.fc17
Comment 10 Fedora Update System 2012-10-05 23:51:01 EDT
Package libreoffice-3.5.7.2-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15506/libreoffice-3.5.7.2-2.fc17
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.