Bug 827878 - OVIRT-SDK: [RFE] preform get() request on proxy construction to validate user credentials
OVIRT-SDK: [RFE] preform get() request on proxy construction to validate user...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-sdk (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1
Assigned To: Michael Pasternak
infra
:
: 827879 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 08:47 EDT by Michael Pasternak
Modified: 2014-01-12 19:37 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.1.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Pasternak 2012-06-03 08:47:04 EDT
Description of problem:

preform get() request on proxy construction to validate user credentials,
otherwise if credentials are incorrect, user will notice that only during
first sdk invocation.
Comment 1 Michael Pasternak 2012-06-03 08:51:32 EDT
*** Bug 827879 has been marked as a duplicate of this bug. ***
Comment 2 Itamar Heim 2012-08-09 04:03:28 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/
Comment 3 Itamar Heim 2012-08-09 04:04:08 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.