Bug 82792 - phoebe2 won't install because of the wrong cdrom iso9660 format
phoebe2 won't install because of the wrong cdrom iso9660 format
Status: CLOSED DUPLICATE of bug 75008
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-26 08:53 EST by Tadej Janež
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2003-01-26 08:53:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030103

Description of problem:
I wanted to install phoebe2 but i couldn't.

It booted fine from the first CD and then I did a mediacheck test and all 3 CDs
passed it. Then I inserted the first CD again and it didn't go further to the
graphical installation screen. This also happens when I skip mediacheck test and
install immediately.

I looked on the tty3 and it stops when loading modules: reiserfs, xfs, lvm-?, ...
On the tty4 it keeps saying wrong cdrom iso9660 format (i don't remember the
exact words) and than it says ATAPI restart completed (or something similar). If
you need exact words I can reproduce this again and write down the messages.

I use a plextor cdrw 241040ta which is connected as the master on the secondary
ide chanel (hdc). I installed all the previous releases (including psyche and
phoebe1) without problems and my hardware hasn't change since then.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot off the first cd
2. press enter (for graphical install)
3. problem is 'here'
    

Actual Results:  install hangs and I have to do a hard reset

Expected Results:  install should proceed to the graphical install

Additional info:
Comment 1 Michael Fulbright 2003-01-27 11:53:29 EST
This sounds like a bad CD. Sometimes a CD can manage to pass the mediacheck and
then fail later.  I would recommend trying the CDs on a different machine and
see if it can install from them as a sanity check.
Comment 2 Tadej Janež 2003-01-29 09:06:39 EST
As you suggested I did a sanity check and the CD works ok on the other computers.

Additionally I wrote down the exact words about the error on tty4
Here they are:
....
<7>ISO 9660 Extentions: RRIP_1991A
<4>Unable to identify CD-ROM format
<4>VFS: Can't find ext2 filesystem on dev loop(7,0)
(the above lines are also the same on the machines that worked with this CD!?)
<4>hdc: irq timeout: status=0xd0 {Busy}
<4>hdc: irq timeout: error=0xd0LastFailedSense 0xd0
<4>hdc: ATAPI reset complete

The last three lines keep repeating and eventually I have to press ctrl-alt-delete.

Hope that helps.

Tadej
Comment 3 Jeremy Katz 2003-01-29 16:53:14 EST
Does it work better if you boot with 'linux ide=nodma'?
Comment 4 Tadej Janež 2003-02-01 08:31:01 EST
I figured out the problem.

It is a really strange one. As I said, the original CD1 didn't work on my
testing computer, however, it worked fine on other computers.
I was really frustrated and I downloaded the first image again and burned it on
another CD (same brand of CDR - BenQ). I burned the new CD with the same burner
(Plextor 241040TA). This burner is also used for reading the CDs during
installation on my testing machine.

And the new CD worked!

So my wild guess is that the burner on my testing machine was more sensitive to
reading  'scratched' or somehow 'bad' CDs than the normal cd-roms on the other
machines that I used as a sanity check.
But how did it (the bad CD) pass the MD5SUM check at the begining of the
installation and then failed later?

I guess this is still a mystery.
Comment 5 Michael Fulbright 2003-02-03 14:10:25 EST
The md5sum test in the loader is not guaranteed to catch all errors. The
installation accesses the CD in a different pattern that the md5sum test (which
accesses it sequentially). I've thought about trying to make the test more
stringent but have not had time.

*** This bug has been marked as a duplicate of 75008 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:51:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.