Bug 828114 - DeviceError: ('device has not been created', '//10.0.0.203/cri2011')
DeviceError: ('device has not been created', '//10.0.0.203/cri2011')
Status: CLOSED DUPLICATE of bug 826492
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 05:35 EDT by markusN
Modified: 2012-06-04 15:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 15:27:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full bug report (63.81 KB, application/x-gzip)
2012-06-04 05:35 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-06-04 05:35:59 EDT
Created attachment 589089 [details]
full bug report

Updating from F16 to F17 lead to a fatal error:

The following was filed automatically by anaconda:
anaconda 17.29 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 702, in _preSetup
    raise DeviceError("device has not been created", self.name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 718, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2012, in _parseOneLine
    device.setup()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2112, in parseFSTab
    device = self._parseOneLine((devspec, mountpoint, fstype, options, dump, passno))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1676, in mountExistingSystem
    fsset.parseFSTab(anaconda=anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 178, in upgradeMountFilesystems
    mountExistingSystem(anaconda, anaconda.upgradeRoot[0], allowDirty = 0)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
    func(*args, **kwargs)
DeviceError: ('device has not been created', '//10.0.0.203/cri2011')


The problem is that the following Windows share entries in /etc/fstab were not ignored:

//10.0.0.203/cri2011 /mnt/IASMA003_NEWCRI cifs user,iocharset=iso8859-15,credentials=/etc/samba/auth.10.0.0.203.netelerm,uid=neteler,file_mode=0664,user_xattr,dir_mode=0775 0 0
//10.0.0.203/SCAMBIA /mnt/IASMA003_SCAMBIA cifs user,iocharset=iso8859-15,credentials=/etc/samba/auth.10.0.0.203.netelerm,uid=neteler,file_mode=0664,user_xattr,dir_mode=0775 0 0
...


Solution:
I copied the /etc/fstab file to /etc/fstab.mybackup, then removed the entries from /etc/fstab and rebooted to successfully upgrade the system.

See related bugs in bug #825500, bug #827470, bug #826492, bug #823048
Comment 1 David Lehman 2012-06-04 15:27:09 EDT

*** This bug has been marked as a duplicate of bug 826492 ***

Note You need to log in before you can comment on or make changes to this bug.