Bug 828142 - new password could be set even without enter old password in TUI upgrade
new password could be set even without enter old password in TUI upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
: 828496 (view as bug list)
Depends On:
Blocks: 828496 837055
  Show dependency treegraph
 
Reported: 2012-06-04 06:54 EDT by haiyang,dong
Modified: 2016-04-26 10:00 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, if the old password was not entered, a new password could be set. This meant that during upgrade, an admin could change the password without ever knowing the previous password. This fix ensures that the previous password has been entered and verified correctly before allowing the password change.
Story Points: ---
Clone Of:
: 828496 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:35:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-06-04 06:54:29 EDT
Description of problem:
leave previous password blank and set new password, TUI upgrade doesn't check the previous.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H first.
2. Boot from PXE choose the latest RHEV-H and press Enter key enter TUI upgrade process.
3. Keep current password blank and input new password, press continue button

Actual results:
1. Not need input current password, upgrade can successful.
2. After reboot, login RHEV-H can success with new password, and fail with old password.

Expected results:
new password only could be set when enter old password in TUI upgrade.

Additional info:
Comment 3 Joey Boggs 2012-06-04 15:49:29 EDT
*** Bug 828496 has been marked as a duplicate of this bug. ***
Comment 6 Mike Burns 2012-06-25 21:32:30 EDT
Can you try this with the final 6.3 version?  My attempts show that it doesn't reproduce in the final version.

Thanks
Comment 9 Mike Burns 2012-06-26 08:51:07 EDT
OK, what I was trying was first trying with incorrect password which set the appropriate variable and caused it to not upgrade.  I reproduced by upgrading and setting no password on the current password line
Comment 20 haiyang,dong 2012-12-16 21:03:00 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Steps to Reproduce:
1. Install RHEV-H first.
2. Boot from PXE choose the latest RHEV-H and press Enter key enter TUI upgrade process.
3. Keep current password blank and input new password, press continue button.

 it will return to current page,new password only could be set when enter old password in TUI upgrade.

so this bug has been fixed, although missed "Current Password is Required" page,
Having bug #887253 to track the creation of an additional popup, change the status into "VERIFIED"
Comment 22 errata-xmlrpc 2013-02-28 11:35:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.