Bug 828311 - System Properties for registered system lists "Arch" as blank
System Properties for registered system lists "Arch" as blank
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Sachin Ghai
: Triaged, ZStream
Depends On: 812417
Blocks: 817658
  Show dependency treegraph
 
Reported: 2012-06-04 10:35 EDT by Chris Pelland
Modified: 2014-09-18 12:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
System Engine's architecture definition lacked an i686 arch. Consequently the Arch for i686 systems displayed as blank. This update adds i686 to the architecture definition. The Arch is no longer blank for i686 systems.
Story Points: ---
Clone Of: 812417
Environment:
Last Closed: 2012-07-10 03:25:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Registered rhel5 client shows 'Arch' value under system properties (63.70 KB, image/png)
2012-06-07 12:28 EDT, Sachin Ghai
no flags Details
Registered rhel6 i386 client shows 'Arch' value under system properties (55.50 KB, image/png)
2012-06-08 02:15 EDT, Sachin Ghai
no flags Details

  None (edit)
Comment 2 Sachin Ghai 2012-06-07 12:27:02 EDT
Verified with following build:

katello-0.1.313-1.el6_3.noarch

And registered following rhel5 machine with latest CFSE server.

[root@dhcp201-154 yum.repos.d]# subscription-manager register --username admin --password admin --force
9c64ec89-841a-4692-b8da-9f61dfe906c7 dhcp201-154.englab.pnq.redhat.com
[root@dhcp201-154 yum.repos.d]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.7 (Tikanga)
[root@dhcp201-154 yum.repos.d]# uname -a
Linux dhcp201-154.englab.pnq.redhat.com 2.6.18-274.el5xen #1 SMP Fri Jul 8 18:18:40 EDT 2011 i686 i686 i386 GNU/Linux
[root@dhcp201-154 yum.repos.d]# 

I can see the Arch value under registered system's properties. Please see the attached screenshot.

I'll test for RHEL6 i386 client too.
Comment 3 Sachin Ghai 2012-06-07 12:28:35 EDT
Created attachment 590236 [details]
Registered rhel5 client shows 'Arch' value under system properties
Comment 4 Sachin Ghai 2012-06-08 02:12:06 EDT
Registered a rhel6.3 beta i386 client with system engine and I can see the Arch value under system properties.
Comment 5 Sachin Ghai 2012-06-08 02:15:03 EDT
Created attachment 590344 [details]
Registered rhel6 i386 client shows 'Arch' value under system properties
Comment 6 Dan Macpherson 2012-06-13 12:21:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
System Engine's architecture definition lacked an i686 arch. Consequently the Arch for i686 systems displayed as blank. This update adds i686 to the architecture definition. The Arch is no longer blank for i686 systems.
Comment 8 errata-xmlrpc 2012-07-10 03:25:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html
Comment 9 Mike McCune 2013-08-16 14:17:56 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.