Bug 828315 - Unmet dependencies for some packages
Unmet dependencies for some packages
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Kedar Bidarkar
repoclosure_hash:ca78a05bede530961d9b...
: Triaged, ZStream
Depends On: 789139
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 10:44 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The inclusion of candlepin-0.6 into System Engine required certain code and database changes for System Engine 1.0.1. This upgrade provides a katello-update script to upgrade to 1.0.1 and provides associated changes in katello-configure. System Engine 1.0.1 now uses candlepin-0.6 correctly.
Story Points: ---
Clone Of: 789139
Environment:
Last Closed: 2012-07-10 03:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 4 Dan Macpherson 2012-06-17 20:19:59 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The inclusion of candlepin-0.6 into System Engine required certain code and database changes for System Engine 1.0.1. This upgrade provides a katello-update script to upgrade to 1.0.1 and provides associated changes in katello-configure. System Engine 1.0.1 now uses candlepin-0.6 correctly.
Comment 7 Mike McCune 2012-06-25 13:17:44 EDT
This bug and the 1.1 bug morphed into the bug that we dumped all the work required to re-package all the candlepin deps, the candlepin 0.6 upgrade as well as the new 'katello-upgrade' script that was required to use Candlepin 0.6.

The tests for this bug should be:

* Can you install and run CFSE 1.0.1 on a fresh system and everything functions fine

* Can you upgrade a CFSE 1.0.0 system to 1.0.1 using katello-upgrade (see comment #5)
Comment 8 Jay Greguske 2012-06-25 14:54:10 EDT
When candlepin was broken out into constituent builds I suspect there is a lot there that we do not actually need to ship, which is why the current repoclosure output is misleading. I'll look at what SAM has and bring in what we need.
Comment 10 errata-xmlrpc 2012-07-10 03:25:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html

Note You need to log in before you can comment on or make changes to this bug.