Bug 828426 - Cannot mount volume sub-directories using NFS from a Solaris client
Cannot mount volume sub-directories using NFS from a Solaris client
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Vivek Agarwal
Sudhir D
:
: 858414 (view as bug list)
Depends On:
Blocks: 858414
  Show dependency treegraph
 
Reported: 2012-06-04 13:43 EDT by Veda Shankar
Modified: 2016-06-12 19:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858414 (view as bug list)
Environment:
Last Closed: 2013-07-22 09:47:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Glusterfs logs (1.95 MB, application/gzip)
2012-06-04 13:43 EDT, Veda Shankar
no flags Details

  None (edit)
Description Veda Shankar 2012-06-04 13:43:52 EDT
Created attachment 589230 [details]
Glusterfs logs

Description of problem:

Customer is getting an error when trying to NFS mount a sub-directory from a Solaris client.  The glusterfs logs are attached.

There was a suggestion to use "mountproto=tcp" option but that is not an available option in Solaris.

gluster> volume info

Volume Name: tvol1
Type: Replicate
Volume ID: 6faf2030-fea4-4398-a039-1d29999d8bae
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: 172.17.9.231:/brick1
Brick2: 172.17.9.232:/brick1
Options Reconfigured:
nfs.register-with-portmap: on
nfs.rpc-auth-allow: 10.125.74.90
nfs.addr-namelookup: off
nfs.disable: off
nfs.export-dir: /gino
features.limit-usage: /gino:10gb
features.quota: on
gluster> 

root@nysolsbx1:~# mount -o proto=tcp,vers=3 nfs://10.125.74.106:38467/tvol1/gino /mnt                                                        
nfs mount: 10.125.74.106: : RPC: Program not registered nfs mount: retrying: /mnt




Version-Release number of selected component (if applicable):

RHS 2.0 Beta2.

How reproducible:

Always.
Comment 2 Krishna Srinivas 2012-07-30 03:24:43 EDT
For now, we only have a workaround:

Hi Rajesh,

Thank you for the workaround, it works fine.
Can we expect a patch in the future release to avoid this procedure ?

Regards,

Anthony

> Date: Thu, 19 Jul 2012 05:30:24 -0400
> From: rajesh@redhat.com
> To: sokar6012@hotmail.com
> CC: gluster-users@gluster.org; sgowda@redhat.com
> Subject: Re: [Gluster-users] NFS subdirectory Solaris client
> 
> fwding from krishna's mail, need to update the docs with this info:
> 
> Here are the steps:
> on linux client machine:
> * make sure you have the directory you want to export is already created, if 
> not create it.
> if /mnt/nfs is the mount point do this:
> mkdir /mnt/nfs/subdir
> * on storage node do:
> gluster volume set <volname> nfs.export-dir /subdir
> gluster volume set <volname> nfs.mount-udp on
> * do a "showmount -e <storage-node-ip>" to see that subdir is exported too.
> * on a LINUX client do this:
> mount -o proto=tcp <storage-node-ip<volname>/subdir /mnt/nfs
> i.e you are mounting the subdir.
> * now on SOLARIS client do this:
> mount nfs://<storage-node-ip<volname>/subdir /mnt/nfs
> you should be able to access the exported subdir on Solaris machine. note 
> that you have to mount the subdir on a linux machine first with proto=tcp 
> before trying to mount on solaris machine.
Comment 3 Krishna Srinivas 2012-11-02 07:53:40 EDT
For now we have the workaround mentioned above. We won't need the workaround when we implement the non blocking UDP-layer. Right now we have only TCP implementation. Solaris nfs client uses UDP for MOUNT operations.
Comment 4 Vivek Agarwal 2013-07-15 08:12:53 EDT
*** Bug 858414 has been marked as a duplicate of this bug. ***
Comment 5 Vivek Agarwal 2013-07-22 09:47:19 EDT
Based on discussion with Sayan, concluded this is not a supported OS.

Note You need to log in before you can comment on or make changes to this bug.