Bug 82849 - Anaconda hangs when installing packages
Anaconda hangs when installing packages
Status: CLOSED DUPLICATE of bug 75008
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 12:49 EST by Nigel Hessey
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Hessey 2003-01-27 12:49:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
Anaconda hangs during upgrade or install while installing the packages.
The hang occurs at random positions, sometimes first package, average roughly
after 300 Mb. 

Hang means the install progress stops, the IDE access light is stuck on.
Ctrl-Alt-F2 (or whatever number it was) gives me a usable prompt, but as soon as
I try to access the linux disc, it too hangs. 

Media check was OK (tried two times).

I had the same problem with (i) hard disk on ATA100 or normal IDE connector on
mainboard (ii) also installing from CD images on my Windows disc (iii) text or
graphics install (iv) with updates and cdread-8.0.img file (v) upgrade or
workstation or custom/minimum installation. 

It did once work (475 Mb) on minimum install, but then I could not figure out
how to get the rest installed with rpm. 

I cleaned DVD, DVD-drive, new DVD cable; all no effect.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Load DVD, boot from DVD, select `upgrade' method; nothing special.
2.Also boot from boot.img on floppy, tell it where cd-images are on Windows disc.
3.
    

Actual Results:  Installation hangs, as described above. Red Hat 7.2 destroyed
(at least for my level of expertise).
The anaconda log file has no error messages, just a list of installed packages,
including the one it stuck on, and with a full-stop at the end of the package name.

Expected Results:  Red Hat 8.0 installed, and certainly not the loss of Red Hat 7.2.

Additional info:

I have an AMD Athlon 1GHz, ASUS A7V mainboard, Asus DVD-drive.

Final workaround: Re-install Red Hat 7.2 from CD and boot to it. Then stick
DVD-ROM in. Brutally insist rpm upgrades or installs everything in a foreach
loop, ignoring all warnings (--nodep etc). Then 7.2 no longer booted, nevermind,
put in the DVD and reboot. Do an 'upgrade': now since everything was already
done the install size was only 175 Mb, which worked (first time, as it
happened). Then fiddle around because some packages were not quite right,
following the wrong (alphabetical) package upgrade sequence. End result: all
working, 4.5 Gbyte of stuff installed.
Comment 1 Jeremy Katz 2003-01-28 00:42:21 EST
Could you verify your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 2 Nigel Hessey 2003-01-29 03:35:52 EST
I did linux mediachack on the DVD; it says media passed, no errors. I have
checked it several (4 I think) times now, always 100 % OK. I have exactly the
same problem installing from CD images on hard disk.
Comment 3 Jeremy Katz 2003-01-29 16:46:16 EST
Are there any error messages on tty4 when the hang occurs?
Comment 4 Nigel Hessey 2003-01-30 03:35:30 EST
Most times when installing hung I went through <ctrl>-<alt>-<F1> to <F8> and
looked for errors etc. Mostly there were no errors mentioned, but sometimes one
of the screens said there was a spurious interrupt from somewhere. I'm afraid I
did not write down the details. It was not there everytime (unless it had
scrolled off the top of the screen). And now that I have a working version of
Red Hat 8.0 (see "Additional Info" in original report) I don't really want to
try re-installing to reproduce the error. 
Comment 5 Michael Fulbright 2003-01-30 15:43:17 EST
If you purchased this media from Red Hat you can contact customer support for
replacement media.

*** This bug has been marked as a duplicate of 75008 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:51:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.