Bug 82855 - Can't install Phoebe2 with no mouse attached to system
Can't install Phoebe2 with no mouse attached to system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 82722 83712 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 14:28 EST by Felipe Alfaro Solana
Modified: 2008-01-17 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2003-01-27 14:28:45 EST
Description of problem:
-----------------------
I have been trying to install Phoebe2 (8.0.93) onto my old PII 300 machine using
only a keyboard (no mouse) by booting off from my SCSI CD-ROM (haven't tried
booting off or installing from the net).

However, just when "anaconda" begins to run, my keyboard stops responding. It
seems the system is responsive as I can see the hDD led blink at some times, but
I can't use ALT-F2 to get to a console or ALT-F4 to see kernel messages. At this
point "anaconda" complains that no mouse has been found and lets me choose
whether I want to perform a text-only install. But since my standard, Spanish
PS/2 Microsoft Natural Elite keyboard has just stop responding I can't do anything.

So, I rebooted and this time, at the ISOLINUX prompt, I entered "linux text" to
perform a text-mode installation. However, the problem was the same: just when
"anaconda" starts detecting the video hardware, mouse, et al, my keyboard stops
responding.

I have found that attaching my Logitech Wheel USB mouse to one of the USB ports
fixes the problem and, in fact, I'm now installing Phoebe2 using keyboard and
mouse in graphical mode.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Phoebe2 beta (8.0.93)... I think this is related to "anaconda" as my keyboard is
working just up until the moment "anaconda" is run. It seems a hardware
detection problem killing the PS/2 keyboard controller.

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Better if you can get to work on this on a machine similar to mine.
2. Make sure no mouse is attached, only a PS/2 keyboard.
3. Boot from CD1
4. The system will start booting, "anaconda" will run and, at that moment, the
keyboard will not respond. Pressing NumLock won't toggle the keyboard led so,
it's evident the keyboard driver is not listening.
    
Actual results:
---------------
Can't install Phoebe2 from CD-ROM with no mouse attached. Doing so, the keyboard
becomes unresponsive.

Expected results:
-----------------
The keyboard shouldn't stop responding after loading "anaconda" while installing
from CD-ROM with no mouse attached.

Additional info:
----------------
My hardware:

Intel AL440-LX motherboard
Pentium II 300 Mhz
384MB RAM
Matrox Millennium G200 AGP with 8MB
Built-in PIIX IDE controller disabled by BIOS (both ports)
Built-in floppy drive controller disabled by BIOS (no floppy drive on this
machine :-))
Adaptec AHA2940-UW PCI SCSI Controller
Quatum XP43550UW UltraSCSI Wide 4,3GB SCSI HDD
Plextor PX-32TS UltraSCSI CD-ROM
Yamaha CRW-4260T SCSI CD-RW
HP STT20000 DAT SCSI Tape
Microsoft Natural Keyboard Elite PS/2
3Com 3C59x NIC
Realtek RTL8129 NIC

I'm installing Phoebe2 by booting off my Plextor SCSI CD-ROM, with no mouse
attached to the system. However, plugging a Logitech Wheel USB mouse makes the
problem described above disappear :-)

Please, don't hesitate to contact me for more info.
Comment 1 Jeremy Katz 2003-01-28 00:32:25 EST
This is fixed post-phoebe2 
Comment 2 Jeremy Katz 2003-01-29 16:55:24 EST
*** Bug 82722 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2003-02-07 12:18:10 EST
*** Bug 83712 has been marked as a duplicate of this bug. ***
Comment 4 Brent Fox 2003-05-25 10:57:00 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.