Bug 828663 - [abrt] python-2.7.3-6.fc17: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] python-2.7.3-6.fc17: Process /usr/bin/python2.7 was killed by signal 1...
Status: CLOSED DUPLICATE of bug 809353
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
abrt_hash:6c96f4d9eea30d0052f81e32e34...
:
: 836812 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 03:13 EDT by markusN
Modified: 2012-07-27 03:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 03:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.62 KB, text/plain)
2012-06-05 03:13 EDT, markusN
no flags Details
File: maps (65.83 KB, text/plain)
2012-06-05 03:13 EDT, markusN
no flags Details
File: dso_list (14.34 KB, text/plain)
2012-06-05 03:13 EDT, markusN
no flags Details
File: build_ids (5.81 KB, text/plain)
2012-06-05 03:13 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-06-05 03:13:14 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/python -Es /usr/bin/sealert -s
comment:        Running abrt, python crashed
crash_function: std::_Rb_tree_insert_and_rebalance
executable:     /usr/bin/python2.7
kernel:         3.3.7-1.fc17.x86_64
pid:            12979
pwd:            /
time:           Tue 05 Jun 2012 09:04:32 AM CEST
uid:            1338
username:       neteler
var_log_messages: Jun  5 09:04:32 north abrt[12997]: Saved core dump of pid 12979 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-06-05-09:04:32-12979 (28217344 bytes)
xsession_errors: 

backtrace:      Text file, 56956 bytes
build_ids:      Text file, 5945 bytes
dso_list:       Text file, 14685 bytes
maps:           Text file, 67407 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/neteler/2

core_backtrace:
:516204cfc31148538d56b21e2f1b945ed50127d4 0x74e47 std::_Rb_tree_insert_and_rebalance(bool, libstdc++.so.6 -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0x9c185 std::_Rb_tree<unsigned liboxygen-gtk.so -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0x9c26b std::_Rb_tree<unsigned liboxygen-gtk.so -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0x999d0 Oxygen::ColorUtils::lowThreshold(Oxygen::ColorUtils::Rgba liboxygen-gtk.so -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0x99adf Oxygen::ColorUtils::backgroundBottomColor(Oxygen::ColorUtils::Rgba liboxygen-gtk.so -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0xcb14a Oxygen::Style::renderWindowBackground(_cairo*, liboxygen-gtk.so -
:ec2fecf0b18dafe4c52a9f09736119843ed4ec1d 0x11195d - liboxygen-gtk.so -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x28dd26 - libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x28ddb5 - libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x14cc3c - libgtk-x11-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x20450 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x27f20e - libgtk-x11-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x14b080 gtk_main_do_event libgtk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x450f9 - libgdk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x3fcb1 - libgdk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x42068 gdk_window_process_all_updates libgdk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x420c9 - libgdk-x11-2.0.so.0 -
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd 0x1eb57 - libgdk-x11-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x149d67 gtk_main libgtk-x11-2.0.so.0 -
:e4ee09219dd69e5a1f6b06fb78c7488a3a6260df 0x1a65a8 - _gtk.so -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdce46 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddc02 PyEval_EvalCode libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf6baa - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf79a2 PyRun_FileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf83bb PyRun_SimpleFileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x109892 Py_Main libpython2.7.so.1.0 -

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-I7xn3dNweS,guid=ab6225ae29f2bb7f23a46fc4000000e0
:XDM_MANAGED=method=classic
:XDG_RUNTIME_DIR=/run/user/neteler
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games
:XDG_VTNR=1
:DM_CONTROL=/var/run/xdmctl
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-I7xn3dNweS,guid=ab6225ae29f2bb7f23a46fc4000000e0
:XDG_SEAT=seat0
:XAUTHORITY=/tmp/.XauthgFzIha
:USER=neteler
:DBUS_STARTER_BUS_TYPE=session
:SHLVL=1
:PWD=/home/neteler
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=neteler
:HOME=/home/neteler

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31402                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31402                31402                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:socket:[116173]
:pos:	0
:flags:	02000002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:socket:[116178]
:pos:	0
:flags:	02004002
:6:socket:[116169]
:pos:	0
:flags:	02004002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:socket:[116183]
:pos:	0
:flags:	02004002
:9:socket:[116184]
:pos:	0
:flags:	02000002
:10:pipe:[116209]
:pos:	0
:flags:	00
:11:socket:[115222]
:pos:	0
:flags:	02004002
:12:anon_inode:inotify
:pos:	0
:flags:	02004000
:13:pipe:[116209]
:pos:	0
:flags:	04001

smolt_data:
:
:
:General
:=================================
:UUID: 33142b9c-cee3-4ba9-ab06-71f6a9c3327b
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5054.09
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     P8700  @ 2.53GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2535
:System Memory: 3943
:System Swap: 3999
:Vendor: Dell Inc.
:System: Precision M4400 
:Form factor: Portable
:Kernel: 3.3.7-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4136:592) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:4136:592) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(32902:10544:4136:592) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10282:4136:592) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:10519:4136:592) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:4341:4136:592) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:16946:32902:4897) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(32902:9288:4136:592) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10549:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(4480:2082:4136:592) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:10554:4136:592) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4136:592) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10558:4136:592) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:1628:4136:592) pci, nvidia, VIDEO, G96M [Quadro FX 770M]
:(4480:1142:4136:592) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(4480:2098:4136:592) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 3826755 1139814 947814 960992 690699 690699
:/dev/sda3 /home ext4 4096 4096 56117990 10189316 7380049 14049280 13606493 13606493
:
Comment 1 markusN 2012-06-05 03:13:24 EDT
Created attachment 589411 [details]
File: backtrace
Comment 2 markusN 2012-06-05 03:13:27 EDT
Created attachment 589412 [details]
File: maps
Comment 3 markusN 2012-06-05 03:13:30 EDT
Created attachment 589413 [details]
File: dso_list
Comment 4 markusN 2012-06-05 03:13:32 EDT
Created attachment 589414 [details]
File: build_ids
Comment 5 Thomas Spura 2012-06-05 15:48:33 EDT
Thanks for filling this bug report.

It looks like this is again a "dbus doesn't support EINVAL" bug like bug #827658:
#30 0x0000003279c47a18 in g_main_context_iterate (context=0x15aa130, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3146

But also might be the same unsupported value in gdk/gtk or a bug in Oxygen.

Not closing as a dub, as I'm quite unsure, where exactly the bug is...
Comment 6 Thomas Spura 2012-07-27 02:53:59 EDT
*** Bug 836812 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Spura 2012-07-27 03:01:50 EDT

*** This bug has been marked as a duplicate of bug 809353 ***

Note You need to log in before you can comment on or make changes to this bug.