Bug 828681 - Document for default buffere mode of fileio is incorrect.
Summary: Document for default buffere mode of fileio is incorrect.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils
Version: 6.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On: 846670
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-05 07:57 UTC by Gris Ge
Modified: 2015-01-04 23:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:48:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0457 normal SHIPPED_LIVE fcoe-target-utils bug fix and enhancement update 2013-02-20 21:07:34 UTC

Description Gris Ge 2012-06-05 07:57:58 UTC
Description of problem:

"targetcli /backstores/fileio/ help create" said:
====
The buffered parameter is a boolean stating whether or not to enable buffered mode. It is disabled by default (synchronous mode).
===

But this how creating LUN output:
===
/backstores/fileio> /backstores/fileio create disk2 /tmp/fcoe-lun2 10G
Using buffered mode.
Created fileio disk2 with size 10G
Entering new node /backstores/fileio/disk2
===

Apparently, the default value is "enable buffer".

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb10-5.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Andy Grover 2012-08-08 19:09:25 UTC
buffered mode got replaced by write_back setting. Default setting for write_back should be documented correctly, i.e. on by default.

Comment 4 Petr Beňas 2012-10-17 12:32:20 UTC
Reproduced in fcoe-target-utils-2.0rc1.fb10-5.el6.noarch and verified in fcoe-target-utils-2.0rc1.fb16-1.el6.noarch.

Comment 6 errata-xmlrpc 2013-02-21 10:48:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html


Note You need to log in before you can comment on or make changes to this bug.