Bug 846670 - targetcli create traceback
Summary: targetcli create traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils
Version: 6.4
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks: 828681
TreeView+ depends on / blocked
 
Reported: 2012-08-08 11:56 UTC by Petr Beňas
Modified: 2015-01-04 23:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:48:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0457 normal SHIPPED_LIVE fcoe-target-utils bug fix and enhancement update 2013-02-20 21:07:34 UTC

Description Petr Beňas 2012-08-08 11:56:59 UTC
Description of problem:
It seems fix for bug 828681 broke targetcli create.

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb16-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. service fcoe-target start
2. targetcli /backstores/fileio create disk /tmp/test 10M
  
Actual results:
Using params size=10M write_back=True sparse=True
Traceback (most recent call last):
  File "/usr/bin/targetcli", line 91, in <module>
    main()
  File "/usr/bin/targetcli", line 74, in main
    shell.run_cmdline(" ".join(sys.argv[1:]))
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 934, in run_cmdline
    self._execute_command(path, command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 909, in _execute_command
    result = target.execute_command(command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_node.py", line 84, in execute_command
    pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1405, in execute_command
    result = method(*pparams, **kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_backstore.py", line 314, in ui_command_create
    write_back=write_back)
TypeError: __init__() got an unexpected keyword argument 'write_back'

Expected results:
Using buffered mode.
Created fileio disk with size 10M
Entering new node /backstores/fileio/disk

Additional info:
This works fine in fcoe-target-utils-2.0rc1.fb10-5.el6.noarch, possibly a regression.

Comment 2 Andy Grover 2012-08-08 14:58:37 UTC
regression.

Comment 3 Andy Grover 2012-08-08 21:17:56 UTC
Try fcoe-target-utils-2.0rc1.fb16-2.el6 and python-rtslib-2.1.fb21-1.el6, should fix it?

Comment 6 Petr Beňas 2012-10-15 11:14:28 UTC
Verified in fcoe-target-utils-2.0rc1.fb16-2.el6 and python-rtslib-2.1.fb21-1.el6.

Comment 8 errata-xmlrpc 2013-02-21 10:48:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html


Note You need to log in before you can comment on or make changes to this bug.