Bug 828766 - [RHEVM] [GUI] Inconsistent presence of the Check Connectivity check-box in the Detach/Attach dialogues for non management networks (DC 3.0 , cluster 3.0)
[RHEVM] [GUI] Inconsistent presence of the Check Connectivity check-box in th...
Status: CLOSED DUPLICATE of bug 823920
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Einav Cohen
yeylon@redhat.com
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 06:34 EDT by Martin Pavlik
Modified: 2016-04-18 03:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 03:56:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Detach dialog (151.12 KB, image/png)
2012-06-05 06:34 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-06-05 06:34:02 EDT
Created attachment 589468 [details]
screenshot of Detach dialog

Description of problem:
Detach dialog for non rhevm network shows Check Connectivity check-box (DC 3.0 , cluster 3.0)
Check connectivity should be available only for rhevm interface.

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
have (DC 3.0 , cluster 3.0)
1. attach network to host interface 
2. go to Hosts -> your host -> Network Interfaces -> Detach
  
Actual results:
Detach dialog for non rhevm network shows Check Connectivity check-box

Expected results:
Detach dialog for non rhevm network does NOT show Check Connectivity check-box

Additional info:
Comment 1 lpeer 2012-06-14 08:18:52 EDT
I am not sure this is a bug.
I know we exposed it in the past only in the management dialog but it was wrong as we can loose connectivity also when changing a network that is not the management network.

We are changing the checkbox name to something that reflects better what this box means -

[] undo changes if loosing connectivity to the host.

Simon can you please confirm the above and close this bug if you agree.
Comment 2 Simon Grinberg 2012-06-14 13:38:30 EDT
(In reply to comment #1)
> I am not sure this is a bug.
> I know we exposed it in the past only in the management dialog but it was
> wrong as we can loose connectivity also when changing a network that is not
> the management network.
> 
> We are changing the checkbox name to something that reflects better what
> this box means -
> 
> [] undo changes if loosing connectivity to the host.
> 
> Simon can you please confirm the above and close this bug if you agree.

I do agree with the claim that at least ATM this is not consistent since you don't have it in the attach network dialogue. However there should always be the option to check connectivity and it should be checked by default. So not only that this should not be removed in 3.1 it should appear in all dialogues. 

I'm not closing ATM, but will get back to this next week with a decision.
Comment 3 Simon Grinberg 2012-06-14 14:00:01 EDT
I've also discussed this with Andy.

1. There is an inconsistency between attach and detach for non-management networks
2. The preferred behavior is to have the check connectivity option and the checkbox should be marked by default since there are situations where networks changes may have mutual effect thus leading to lose of connectivity.

Thus the fix should actually be "Add the checkbox to the attach network dialog" Instead of closing this bug should be used to fix the inconstancy the other way.
Comment 5 lpeer 2012-07-17 03:56:12 EDT

*** This bug has been marked as a duplicate of bug 823920 ***

Note You need to log in before you can comment on or make changes to this bug.