Bug 82881 - OS Error:[Errno 12] cannot allocate memory aka Installation troubles
OS Error:[Errno 12] cannot allocate memory aka Installation troubles
Status: CLOSED DUPLICATE of bug 76123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 21:06 EST by Sean Wielusz
Modified: 2006-02-21 13:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Wielusz 2003-01-27 21:06:55 EST
Description of problem:
Anaconda is not "locating memory" before installing

Version-Release number of selected component (if applicable):
Redhat Linux 8

How reproducible:
happens everytime I try to install RH8 onto my computer

Steps to Reproduce:
1.Format hard drive
2.re-partion disk, in Linux friendly partions
3.Everything's good right?
4.Install Redhat 8....
5.Oh, RH8 can't locate memory bug message comes up, better go report it to 
bugzilla.com
    
Actual results:
nothing! THe disk partions are fine, Fdisk finds them, disk druid finds and 
recognizes them; but when it comes to actually installing the packages to the 
computer...it all goes to hell, the bug report thing comes up, and that's it.

Expected results:
I don't know, RH8 actually installing on to my now OS-less paper weight

Additional info:
Computer specifics:
HP XE735
Hard drive = 16 gigs
Ram= 64 mb
proccesor= Intel Celeron 600 Mhz
Windows ME was originally installed

the bug report DID NOT save the diskette, as it claimed, but the last line 
was...

 File "/usr/lib/anaconca/iutil.py",line 66,in execWithRedirect
  childpid=os.fork()
OS Error:[Errno 12] cannot allocate memory

I believe it to have something to do with the partioning of my ex-Windows 
HDrive; however, it has all been formatted and RE PARTIONED in Linux friendly 
partions. Easy install my ass RH8 :) 
so yah, Save My Computer...
Comment 1 Michael Lee Yohe 2003-01-28 10:48:55 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.
Comment 2 Jeremy Katz 2003-01-29 16:44:18 EST

*** This bug has been marked as a duplicate of 76123 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.