Bug 829081 - SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the netlink_route_socket .
SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the netlin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:78682615ba124d10450f1b50b07...
:
: 829091 829092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 18:16 EDT by heber
Modified: 2012-06-16 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-16 20:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description heber 2012-06-05 18:16:31 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 06 Jun 2012 12:12:51 AM CEST

description:
:SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the netlink_route_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed create access on the  netlink_route_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep nova-cert /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:nova_cert_t:s0
:Target Context                system_u:system_r:nova_cert_t:s0
:Target Objects                 [ netlink_route_socket ]
:Source                        nova-cert
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May
:                              21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 06 Jun 2012 12:02:20 AM CEST
:Last Seen                     Wed 06 Jun 2012 12:02:20 AM CEST
:Local ID                      c8e39ebe-da26-4a68-b4c8-eda00f559971
:
:Raw Audit Messages
:type=AVC msg=audit(1338933740.709:298): avc:  denied  { create } for  pid=3246 comm="nova-cert" scontext=system_u:system_r:nova_cert_t:s0 tcontext=system_u:system_r:nova_cert_t:s0 tclass=netlink_route_socket
:
:
:type=SYSCALL msg=audit(1338933740.709:298): arch=x86_64 syscall=socket success=no exit=EACCES a0=10 a1=3 a2=0 a3=238 items=0 ppid=1 pid=3246 auid=4294967295 uid=162 gid=162 euid=162 suid=162 fsuid=162 egid=162 sgid=162 fsgid=162 tty=(none) ses=4294967295 comm=nova-cert exe=/usr/bin/python2.7 subj=system_u:system_r:nova_cert_t:s0 key=(null)
:
:Hash: nova-cert,nova_cert_t,nova_cert_t,netlink_route_socket,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-07 12:56:52 EDT
Fixed in selinux-policy-3.10.0-129.fc17
Comment 2 Daniel Walsh 2012-06-07 12:57:22 EDT
*** Bug 829091 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2012-06-07 12:57:38 EDT
*** Bug 829092 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-06-11 17:00:32 EDT
selinux-policy-3.10.0-130.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-130.fc17
Comment 5 Fedora Update System 2012-06-15 19:57:59 EDT
Package selinux-policy-3.10.0-130.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-130.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9520/selinux-policy-3.10.0-130.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-16 20:02:55 EDT
selinux-policy-3.10.0-130.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.