Bug 829091 - SELinux is preventing /usr/bin/python2.7 from 'nlmsg_read' accesses on the netlink_route_socket .
SELinux is preventing /usr/bin/python2.7 from 'nlmsg_read' accesses on the ne...
Status: CLOSED DUPLICATE of bug 829081
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0387e7f9676d40332cba7984a8f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 19:30 EDT by heber
Modified: 2012-06-07 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 12:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description heber 2012-06-05 19:30:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 06 Jun 2012 01:29:44 AM CEST

description:
:SELinux is preventing /usr/bin/python2.7 from 'nlmsg_read' accesses on the netlink_route_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed nlmsg_read access on the  netlink_route_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep nova-cert /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:nova_cert_t:s0
:Target Context                system_u:system_r:nova_cert_t:s0
:Target Objects                 [ netlink_route_socket ]
:Source                        nova-cert
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May
:                              21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Wed 06 Jun 2012 12:51:56 AM CEST
:Last Seen                     Wed 06 Jun 2012 01:28:51 AM CEST
:Local ID                      4192dc9b-66c5-4aad-b9da-c7bcaf3bd96e
:
:Raw Audit Messages
:type=AVC msg=audit(1338938931.341:241): avc:  denied  { nlmsg_read } for  pid=906 comm="nova-cert" scontext=system_u:system_r:nova_cert_t:s0 tcontext=system_u:system_r:nova_cert_t:s0 tclass=netlink_route_socket
:
:
:type=SYSCALL msg=audit(1338938931.341:241): arch=x86_64 syscall=sendto success=yes exit=ENOTDIR a0=9 a1=7fffdd1f4520 a2=14 a3=0 items=0 ppid=1 pid=906 auid=4294967295 uid=162 gid=162 euid=162 suid=162 fsuid=162 egid=162 sgid=162 fsgid=162 tty=(none) ses=4294967295 comm=nova-cert exe=/usr/bin/python2.7 subj=system_u:system_r:nova_cert_t:s0 key=(null)
:
:Hash: nova-cert,nova_cert_t,nova_cert_t,netlink_route_socket,nlmsg_read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-07 12:57:22 EDT

*** This bug has been marked as a duplicate of bug 829081 ***

Note You need to log in before you can comment on or make changes to this bug.