Bug 829197 - samba-common , warning: %post(samba-common-2:3.6.5-88.el7.1.x86_64) scriptlet failed, exit status 127
samba-common , warning: %post(samba-common-2:3.6.5-88.el7.1.x86_64) scriptlet...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
: 834209 (view as bug list)
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2012-06-06 04:17 EDT by Petr Sklenar
Modified: 2014-05-06 09:16 EDT (History)
6 users (show)

See Also:
Fixed In Version: samba-4.0.6-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-06 09:16:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-06-06 04:17:53 EDT
Description of problem:
Default install produced errors in install.log:

Version-Release number of selected component (if applicable):
samba-common-3.6.5-88.el7.1.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. yum install samba-common -y
2.
3.
  
Actual results:

08:07:21 Installing samba-common-3.6.5-88.el7.1.x86_64
/var/tmp/rpm-tmp.OBXLMV: line 2: /bin/systemd-tmpfiles: No such file or directory
warning: %post(samba-common-2:3.6.5-88.el7.1.x86_64) scriptlet failed, exit status 127

Expected results:
no warning

Additional info:
Comment 4 Rex Dieter 2012-06-18 14:11:18 EDT
/bin is supposed to be symlink to /usr/bin so not sure how or why this would happen

In particular, I'm not sure it is wise to use /usr/sbin/ldconfig in scriptlets, this is busted on rawhide causing builds to fail:
DEBUG util.py:257:  Error: Package: 2:libsmbclient-3.6.5-89.fc18.1.x86_64 (build)
DEBUG util.py:257:             Requires: /usr/sbin/ldconfig
Comment 5 Andreas Schneider 2012-06-19 05:16:11 EDT
Well then this needs to be fixed and documented in rawhide.


Why do we do the usrmove if /usr/sbin/ldconfig is wrong? I don't think this is a Samba bug then.
Comment 6 Rex Dieter 2012-06-19 09:25:08 EDT
Packaging guidelines (still) say to use, /sbin/ldconfig.  I'd recommend you continue to do so.  I'd recommend doing the same for systemd too, fwiw.

The issue as reported in comment #1 is indeed not samba's fault or bug.  It's some usrmove (or systemd) failure.
Comment 7 Kay Sievers 2012-06-19 20:40:37 EDT
glibc.rpm has not moved to /usr so far, so nothing explicitly provides:
  /usr/bin/ldconfig
for RPM, and therefore there can not be a Requires: (RPM adds that if you use
that path) inside a transaction that has it not already installed, even when
the binary will finally end up there.

Either glibc would need to move to /usr, or it will need an explicit
Provides: /usr/bin/ldconfig to make things like the samba spec file work.

There is no real need to convert these paths to the /usr locations.

The error in comment#0 is during install when systemd is not installed
before samba?

I doubt it can be fixed with changing the called paths, they are both
valid if the tool is there.

Not sure, but it might rather need a "Requires(post): systemd" to enforce
proper install ordering.
Comment 8 Bruno Wolff III 2012-06-21 11:28:52 EDT
Note that this issue has broken things for me. Both building live images using f17 updates-testing and doing an update of glibc from f17 updates-testing were broken.
Comment 9 Jeff Law 2012-06-21 14:19:52 EDT
*** Bug 834209 has been marked as a duplicate of this bug. ***
Comment 10 Harald Reindl 2012-06-22 09:13:47 EDT
the not for UsrMove prepared bash-package is the root cause of these problems
https://bugzilla.redhat.com/show_bug.cgi?id=834571

Note You need to log in before you can comment on or make changes to this bug.