Bug 834209 - 2.15-47.fc17 -> broken dep if 3.6.5-89.fc17 is installed
2.15-47.fc17 -> broken dep if 3.6.5-89.fc17 is installed
Status: CLOSED DUPLICATE of bug 829197
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 04:45 EDT by Harald Reindl
Modified: 2016-11-24 10:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 14:19:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2012-06-21 04:45:08 EDT
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket glibc.x86_64 0:2.15-47.fc17 markiert, um aktualisiert zu werden
---> Paket glibc.x86_64 0:2.15-48.fc17 markiert, um an update zu werden
---> Paket glibc-common.x86_64 0:2.15-47.fc17 markiert, um aktualisiert zu werden
---> Paket glibc-common.x86_64 0:2.15-48.fc17 markiert, um an update zu werden
---> Paket glibc-devel.x86_64 0:2.15-47.fc17 markiert, um aktualisiert zu werden
---> Paket glibc-devel.x86_64 0:2.15-48.fc17 markiert, um an update zu werden
---> Paket glibc-headers.x86_64 0:2.15-47.fc17 markiert, um aktualisiert zu werden
---> Paket glibc-headers.x86_64 0:2.15-48.fc17 markiert, um an update zu werden
--> Verarbeite Abhängigkeiten: /usr/sbin/ldconfig für Paket: 2:samba-common-3.6.5-89.fc17.1.x86_64
--> Verarbeite Abhängigkeiten: /usr/sbin/ldconfig für Paket: 2:libsmbclient-3.6.5-89.fc17.1.x86_64
--> Abhängigkeitsauflösung beendet
Fehler: Paket: 2:samba-common-3.6.5-89.fc17.1.x86_64 (@/samba-common-3.6.5-89.fc17.1.x86_64)
            Benötigt: /usr/sbin/ldconfig
            Entfernen: glibc-2.15-47.fc17.x86_64 (@/glibc-2.15-47.fc17.x86_64)
                Nicht gefunden
            Aktualisiert durch: glibc-2.15-48.fc17.x86_64 (updates-testing)
                Nicht gefunden
Fehler: Paket: 2:libsmbclient-3.6.5-89.fc17.1.x86_64 (@/libsmbclient-3.6.5-89.fc17.1.x86_64)
            Benötigt: /usr/sbin/ldconfig
            Entfernen: glibc-2.15-47.fc17.x86_64 (@/glibc-2.15-47.fc17.x86_64)
                Nicht gefunden
            Aktualisiert durch: glibc-2.15-48.fc17.x86_64 (updates-testing)
                Nicht gefunden
 Sie können versuchen mit --skip-broken das Problem zu umgehen.
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Harald Reindl 2012-06-21 04:53:08 EDT
interesting: if i remove the both samba-packages with "rpm -e --nodeps" glibc is updated and after that i can download the removed samba-packages and they are installing fine with "yum install libsmbclient-3.6.5-89.fc17.1.x86_64.rpm samba-common-3.6.5-89.fc17.1.x86_64.rpm"

i really do not understand what is going on here
Comment 2 Jeff Law 2012-06-21 11:09:19 EDT
Can you get the error/warning messages from #1 in English please?  Without knowing exactly what the error messages are saying, I can't even hazard a good guess as to what's going on.

jeff
Comment 3 Harald Reindl 2012-06-21 13:29:17 EDT
2:samba-common-3.6.5-89.fc17.1.x86_64 requires /usr/sbin/ldconfig

the strange is if i remove "samba-common" and "libsmbclient" with "rpm -e --nodpes", update glibc and reinstall the both samba packages dependencies are happy and all is fine
Comment 4 Jeff Law 2012-06-21 14:03:30 EDT
Harald, I think the underlying problem has something to do with you installing glibc-2.15-47 from the updates-testing repo and it's no longer available as it was obsoleted by 2.15-48 in updates-testing.  That's confusing something, but I can't really tell what because my German is limited at best.
Comment 5 Harald Reindl 2012-06-21 14:10:38 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=326776

this sounds to be the reason
i linked a samba-bugreport to this one

i know i am crazy using koji-packages but i am at vacation so it's not a big deal if something is a little bit broken :-)
Comment 6 Jeff Law 2012-06-21 14:19:51 EDT

*** This bug has been marked as a duplicate of bug 829197 ***
Comment 7 Harald Reindl 2012-06-22 09:13:32 EDT
the not for UsrMove prepared bash-package is the root cause of these problems
https://bugzilla.redhat.com/show_bug.cgi?id=834571

Note You need to log in before you can comment on or make changes to this bug.