Bug 829267 - listen_tls prevents libvirt (and in a consequence also ovirt-early) from starting
listen_tls prevents libvirt (and in a consequence also ovirt-early) from star...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks: 824420
  Show dependency treegraph
 
Reported: 2012-06-06 06:57 EDT by Fabian Deutsch
Modified: 2016-04-26 16:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 09:35:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-06-06 06:57:37 EDT
Description of problem:
Bug #810272 enabled listen_tls=1 (default) for libvort again. The problem for node is that libvrt fails to start in this case, because appropriate certificates are missing in /etc/pki/CA/
Normally those certificates are deployed when node is registering to engine.

Version-Release number of selected component (if applicable):
F17



If listen_tls requires certificates and they are not provided by default it makes no sense to enable it by default.
Comment 1 Fabian Deutsch 2012-06-06 09:07:46 EDT
libvirt is needed to detect whether we run in a virt. env. or not.

On F17 we can drop the dependency on libvirt because systemd provides way to detect if we a run in a virt. env.

http://gerrit.ovirt.org/5100

Note You need to log in before you can comment on or make changes to this bug.