Bug 829303 - `rhsm list --available --all` fails with permissions error
`rhsm list --available --all` fails with permissions error
Status: CLOSED DUPLICATE of bug 828978
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
: Regression, Triaged
Depends On:
Blocks: 828358
  Show dependency treegraph
 
Reported: 2012-06-06 08:22 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 11:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-06-06 08:22:41 EDT
Description of problem:
Recent 1.0.1 puddle contains regression issue seems on:
subscription-manager list --available --all
---
User 2821febe-8f7e-44c9-938d-05f7a23ed016 is not allowed to access api/candlepin_proxies/get
---

Version-Release number of selected component (if applicable):
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
pulp-selinux-server-1.0.4-1.el6.noarch
katello-selinux-0.1.10-1.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-foreman-0.1.313-1.el6_3.noarch
katello-configure-0.1.109-1.el6_3.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-0.1.108-1.el6_3.noarch
katello-cli-0.1.108-1.el6_3.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-qpid-0.14-7.el6_2.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-common-1.0.4-1.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-candlepin-0.1.313-1.el6_3.noarch
katello-0.1.313-1.el6_3.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-0.17-1.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.0.7-1.el6_3.noarch
candlepin-0.6.5-1.el6_2.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.0.4-1.el6.noarch
katello-common-0.1.313-1.el6_3.noarch
katello-glue-pulp-0.1.313-1.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64

subscription-manager-0.96.18-1.el6_2.x86_64
How reproducible:
always on provided puddle: 2012-06-05.1

Steps to Reproduce:
1. prepare provider/product/repo
2. sync the repo
3. create an env and promote the repo content to there
4. rhsm register a system to that org/env.
5. run: subscription-manager list --available --all
  
Actual results:
User 2821febe-8f7e-44c9-938d-05f7a23ed016 is not allowed to access api/candlepin_proxies/get

Expected results:
no tracebacks. It's a regression issue. recent latest rc1 CFSE 1.0 is fine.

Additional info:
Comment 2 Garik Khachikyan 2012-06-07 05:02:31 EDT
seems reported before as: https://bugzilla.redhat.com/show_bug.cgi?id=828978
Comment 3 Garik Khachikyan 2012-06-07 05:37:48 EDT
same symptoms on calling:

subscription-manager subscribe --pool ff80808137c22d5f0137c6431de0000a
User 9d9fb135-240c-4f44-a194-3d83761c25f3 is not allowed to access api/candlepin_proxies/post
User 9d9fb135-240c-4f44-a194-3d83761c25f3 is not allowed to access api/candlepin_proxies/get
Comment 5 Mike McCune 2012-06-13 11:21:00 EDT

*** This bug has been marked as a duplicate of bug 828978 ***

Note You need to log in before you can comment on or make changes to this bug.