Bug 829328 - [RFE] Delete images from imagefactory/iwhd when deleting an image in conductor
[RFE] Delete images from imagefactory/iwhd when deleting an image in conductor
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity medium
: 2.0.0
: ---
Assigned To: Ian McLeod
Rehana
: FutureFeature, Triaged
: 835189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 09:34 EDT by Giulio Fidente
Modified: 2013-01-29 11:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 11:11:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio Fidente 2012-06-06 09:34:25 EDT
Deleting images from Conductory doesn't cleanup imagefactory/iwhd images repo

# curl -X DELETE --user admin:password https://localhost/conductor/api/images/1ba5412e-afd3-11e1-a6ac-00101848317e -k

<image href='https://localhost/conductor/api/images/1ba5412e-afd3-11e1-a6ac-00101848317e' id='1ba5412e-afd3-11e1-a6ac-00101848317e'>
<status>DELETED</status>
<content>
</content>
</image>

# ll /var/lib/imagefactory/images/
total 1079948
-rw-------. 1 root root 1105985536 Jun  6 14:37 rhevm-image-3a695544-bb47-45eb-92e8-a172024afa0b.dsk
Comment 1 Dave Johnson 2012-08-08 14:56:45 EDT
*** Bug 835189 has been marked as a duplicate of this bug. ***
Comment 2 Mike Orazi 2012-08-09 11:23:04 EDT
This is a feature that will land in 2.0
Comment 3 Giulio Fidente 2012-10-31 10:19:03 EDT
as an update, this seems to have been already partially implemented in:

iwhd-1.5-2.el6.x86_64
imagefactory-1.0.2-1.el6cf.noarch

the iwhd repo directories:

./target_images
./provider_images
./images
./builds

get cleared up when deleting a build in conductor; the directories:

./icicles
./templates

they still contain instead files from deleted images
Comment 4 Mike Orazi 2013-01-29 11:11:58 EST
This will be addressed when imgfac 2.0/tim is integrated, closing it on the present stream.

Note You need to log in before you can comment on or make changes to this bug.