Bug 835189 - image delete should delete off of filesystem
image delete should delete off of filesystem
Status: CLOSED DUPLICATE of bug 829328
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 15:01 EDT by Dave Johnson
Modified: 2012-08-29 10:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 14:56:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-06-25 15:01:29 EDT
Description of problem:
==============================
Image deletes in the frontend should probably be cleaning up images on the filesystem.  I noticed that when I deleted the image through the ui, the target_image on the filesystem stuck around in /var/lib/imagefactory/images directory.  In my case, I had a small filesystem so eventhough I was deleting through the web ui, the filesystem still filled up and killed the app.


Version-Release number of selected component (if applicable):
aeolus-conductor-0.8.31-1.el6cf.noarch


How reproducible:  100%


Steps to Reproduce:
1.  create a image through the web ui
2.  find it on the file system...  /var/lib/imagefactory/images
3.  delete the image in the ui
4.  see the image still exists on the file system
  
Actual results:
image still exists

Expected results:
image deletes off of filesystem

Additional info:
Comment 3 Dave Johnson 2012-08-07 14:36:27 EDT
moving back into v1.1 for consideration
Comment 4 Dave Johnson 2012-08-08 14:56:45 EDT

*** This bug has been marked as a duplicate of bug 829328 ***

Note You need to log in before you can comment on or make changes to this bug.