Bug 829532 - uuid fails to generate v1 uuids based on local MAC address
uuid fails to generate v1 uuids based on local MAC address
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: uuid (Show other bugs)
16
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
: 847490 (view as bug list)
Depends On:
Blocks: 833429
  Show dependency treegraph
 
Reported: 2012-06-06 21:53 EDT by Philip Prindeville
Modified: 2013-06-25 10:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: uuid-1.6.2-7.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 833429 (view as bug list)
Environment:
Last Closed: 2012-08-24 22:55:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for EL6 and F16 to use getifaddrs() on linux (5.09 KB, patch)
2012-06-06 21:53 EDT, Philip Prindeville
no flags Details | Diff
Fix for EL6 and F16 to use getifaddrs() on linux (5.56 KB, patch)
2012-06-07 00:43 EDT, Philip Prindeville
philipp: review? (steve)
Details | Diff

  None (edit)
Description Philip Prindeville 2012-06-06 21:53:06 EDT
Created attachment 590037 [details]
Fix for EL6 and F16 to use getifaddrs() on linux

Description of problem:

When running on machines which have the high-bit set (0x80) in the MAC address, this is incorrectly interpreted as the MAC field being unset (i.e. not matching interfaces found).

Also, the Linux version was not using getifaddrs() to detect NICs (due to the incorrect dependency on HAVE_NET_IF_DL_H).

Version-Release number of selected component (if applicable):

1.6.2

How reproducible:

N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Philip Prindeville 2012-06-07 00:43:14 EDT
Created attachment 590064 [details]
Fix for EL6 and F16 to use getifaddrs() on linux
Comment 2 Philip Prindeville 2012-06-16 18:41:34 EDT
Do I need to do anything else to advance this?
Comment 3 Fedora Update System 2012-08-13 07:07:44 EDT
uuid-1.6.2-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/uuid-1.6.2-9.fc16
Comment 4 Fedora Update System 2012-08-13 07:07:56 EDT
uuid-1.6.2-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/uuid-1.6.2-11.fc17
Comment 5 Michal Hlavinka 2012-08-13 07:08:15 EDT
*** Bug 847490 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-08-13 20:51:58 EDT
Package uuid-1.6.2-9.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing uuid-1.6.2-9.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11800/uuid-1.6.2-9.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-08-24 22:55:50 EDT
uuid-1.6.2-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-08-24 23:05:30 EDT
uuid-1.6.2-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Maurizio 2013-06-25 10:19:28 EDT
i cant set uuid and mac   imposible to use this option uuid -o

Note You need to log in before you can comment on or make changes to this bug.