Bug 847490 - uuid does not generate UUIDs based on global MAC address
uuid does not generate UUIDs based on global MAC address
Status: CLOSED DUPLICATE of bug 829532
Product: Fedora
Classification: Fedora
Component: uuid (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-12 02:15 EDT by Majid Azimi
Modified: 2012-08-13 07:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 07:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Majid Azimi 2012-08-12 02:15:38 EDT
Description of problem:

OSSP uuid package fail to generate UUID based on global mac address if the name of interface is not "eth0". it falls back to local multicast mode. the source of uuid_mac.c include:

    if ((s = socket(PF_INET, SOCK_DGRAM, 0)) < 0)
        return FALSE;
    sprintf(ifr.ifr_name, "eth0");
    if (ioctl(s, SIOCGIFHWADDR, &ifr) < 0) {
        close(s);
        return FALSE;
    }

As you see if the interface name is not eth0(mine is p4p1 on fedora 17 generated by NetworkManager) it will fail.
Comment 1 Michal Hlavinka 2012-08-13 07:08:15 EDT

*** This bug has been marked as a duplicate of bug 829532 ***

Note You need to log in before you can comment on or make changes to this bug.