Bug 829858 - rhc domain status check fails for missing .ssh/config but shouldn't
rhc domain status check fails for missing .ssh/config but shouldn't
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
: 831009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 13:07 EDT by Clayton Coleman
Modified: 2015-05-14 21:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.94.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-06-07 13:07:40 EDT
I don't believe we need .ssh/config anymore, but the check fails because it doesn't exist.  We should check permissions and fail if they are wrong, but if the file doesn't exist we should be able to continue.  Update the check.

/home/prateek/.gem/ruby/1.9.1/gems/rhc-0.93.18/bin/rhc-chk:107: Use RbConfig instead of obsolete and deprecated Config.
Loaded suite /usr/local/bin/rhc-chk
Started
..Enter PEM pass phrase:
..F
===============================================================================
Failure:
test_05_ssh_config(Test3_SSH)
    [/home/prateek/.gem/ruby/1.9.1/gems/rhc-0.93.18/bin/rhc-chk:347:in `check_permissions'
     /home/prateek/.gem/ruby/1.9.1/gems/rhc-0.93.18/bin/rhc-chk:317:in `test_05_ssh_config']:
File /home/prateek/.ssh/config does not exist, cannot check permissions.
<false> is not true.
===============================================================================
..

Finished in 19.03752593 seconds.
Comment 1 John (J5) Palmieri 2012-06-08 13:26:32 EDT
Fixed.  We no longer test for .ssh/config
Comment 2 Xiaoli Tian 2012-06-11 21:16:08 EDT
*** Bug 831009 has been marked as a duplicate of this bug. ***
Comment 3 Rony Gong 2012-06-11 21:49:59 EDT
verified, fix version:
rhc-0.94.1-1.el6_2.noarch
devenv_1827

[rony@localhost .ssh]$ eval `ssh-agent`; ssh-add ~/.ssh/id_rsa; rhc domain status -px
Agent pid 17333
Identity added: /home/rony/.ssh/id_rsa (/home/rony/.ssh/id_rsa)
Loaded suite /usr/bin/rhc-chk
Started
......

Finished in 5.505295 seconds.

6 tests, 18 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications
100% passed

1.09 tests/s, 3.27 assertions/s

Note You need to log in before you can comment on or make changes to this bug.