Bug 830047 - Yum Failure
Yum Failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
: Reopened
: 830327 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 01:00 EDT by Rusty
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 15:38:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rusty 2012-06-08 01:00:00 EDT
Description of problem:
Transaction Summary
======================================================================================================================================================================
Install   2 Packages (+27 Dependent packages)
Upgrade  78 Packages (+ 6 Dependent packages)

Total size: 168 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
libcups.so.2 is needed by gtk2-2.24.10-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 180 pre-existing rpmdb problem(s), 'yum check' output follows:
git-email-1.7.7.6-1.fc16.noarch has missing requires of git = ('0', '1.7.7.6', '1.fc16')


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rusty 2012-06-08 01:07:15 EDT
How to reproduce:

1. yum update  gdk-pixbuf2 gedit gimp gimp-help gimp-help-browser gimp-libs git git-cpan-patch git-email glade-devel glade-libs glade3-libgladeui-devel glib-networking glib2 glib2-devel glibc glibmm24-devel glpk glusterfs glusterfs-fuse gmime gnome-backgrounds gnome-color-manager gnome-desktop3 gnome-games gnome-games-help gnome-menus gnome-online-accounts gnome-packagekit gnome-panel gnome-panel-libs gnome-python2-extras gnome-python2-gnomeprint gnome-python2-gtkspell gnome-python2-gtkspell gnome-session gnome-session-xsession gnome-settings-daemon gnome-shell gnome-themes-standard gnumeric gnuplot gnuplot-common gnutls goffice gpgme gramps graphviz graphviz-gd grisbi grubby gsettings-desktop-schemas gsl gsl-devel gtk2 gtksourceview3 gtkspell gts gwenhywfar gwenhywfar-gui-qt4 hdf5 hdparm hnb htmldoc httpcomponents-client ibus ibus-gnome3 ibus-gtk2 ibus-gtk3 ibus-hangul ibus-libs idm-console-framework itext itext-core jasper-libs java-1.5.0-gcj java_cup.noarch jetty.noarch jss keyutils-libs kmymoney kmymoney-libs koffice-core koffice-filters koffice-karbon koffice-karbon-libs koffice-kdchart koffice-kexi koffice-kexi-driver-mysql koffice-kexi-driver-pgsql koffice-kexi-libs koffice-kplato koffice-kplato-libs koffice-kpresenter koffice-kpresenter-libs koffice-krita koffice-krita-libs koffice-kspread koffice-kword koffice-kword-libs koffice-libs koffice-okular-odpgenerator koffice-suite krb5-devel krb5-libs krb5-workstation

2. Bunch of koffice errors 

3.Reported to run saved transaction:

zlib-1.2.5-6.fc17.x86_64 is a duplicate with zlib-1.2.5-6.fc16.i686
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-06-08.00-51.VmU4Lz.yumtx

4.Reran and the error above was declared.
Comment 2 Rusty 2012-06-08 17:14:20 EDT
*** Bug 830327 has been marked as a duplicate of this bug. ***
Comment 3 Rusty 2012-06-09 13:41:00 EDT
Here is another one; this time I was using the GUI doing a fix installation after a  large install of most of the KDE programs. Here is the similar report:

ERROR with transaction check vs depsolve:
librpcsecgss.so.3()(64bit) is needed by nfs-utils-lib-devel-1.1.5-6.fc17.x86_64

All these errors come after an upgrade from FC14 to FC16 then to FC17. I have a similar situation with an upgrade from FC16 to FC17. All the machines are network conneced all the time; why does the upgrade procedure grab the latest off the Update URL as a full install does. I even had to do a Kernel install/upgrade when I finished the install showing that the latest was not searched for.

A normal install does grab the latest from the web when doing the install. So should the updates. I am running AMD 64 bit a single core Notebook, a Dual Core Desktop and a Quad core Desk top. all machines were upgraded. All machines are giving me the same problem. This is not a good release strategy.

Please let me know of a fix to yum so I can put the machines back into service. Thanks.
Comment 4 James Antill 2012-06-11 11:06:41 EDT
 As it says:

> ** Found 180 pre-existing rpmdb problem(s), 'yum check' output follows:
> git-email-1.7.7.6-1.fc16.noarch has missing requires of git = ('0', '1.7.7.6', '1.fc16')

...yum isn't going to be happy until these are fixed. You can use install/remove/reinstall/etc. to fix them.
Comment 5 Rusty 2012-06-12 09:22:45 EDT
I find this unacceptable. This system and the others that are having the problem are upgraded systems, and the packages that are duplicates are packages that are trying to be re-installed to add the older version from an older version of the OS.

Should the upgrade not clean up the old packages during an upgrade? I think so!

Note You need to log in before you can comment on or make changes to this bug.